Opened 3 years ago

Closed 3 years ago

#13525 closed Bug (fixed)

[Edge] Page refresh when I press 'view source'

Reported by: Bert Hankes Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: UI : Source View Version: 4.5.0
Keywords: Edge Cc:

Description

When using Spartan in Windows build 10116 the Source is not working... It issues a page refresh.

Change History (14)

comment:1 Changed 3 years ago by Tade0

Problem persists in build 10162.

comment:2 Changed 3 years ago by Jakub Ś

Keywords: Edge added; spartan source removed
Status: newconfirmed

The 4.5.1 as well as latest major all have this problem.

comment:3 Changed 3 years ago by Piotr Jasiun

Summary: Spartan: Windows 10166 unable to 'view source'[Edge] Windows 10166 unable to 'view source'

comment:4 Changed 3 years ago by Piotr Jasiun

Looks like a serious issue. When I press Souce button the website is refreshed and I am losing whole my edited content. I also confirm it in 10162.

comment:5 Changed 3 years ago by Piotr Jasiun

Summary: [Edge] Windows 10166 unable to 'view source'[Edge] Page refresh when I press 'view source'

comment:6 Changed 3 years ago by Olek Nowodziński

Component: GeneralUI : Source View
Milestone: CKEditor 4.5.2
Priority: NormalHigh

It's a critical issue because user loses the content. Please make sure to have the latest Edge installed when fixing the issue.

comment:7 Changed 3 years ago by Bert Hankes

Problem persists in build 10240 (windows 10 RTM).

comment:8 Changed 3 years ago by Tade0

Owner: set to Tade0
Status: confirmedassigned

comment:9 Changed 3 years ago by Tade0

Problem persists in the latest build (which doesn't display the build number).

The browser requires restarting each time the bug occurs.

comment:10 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.2
Owner: Tade0 deleted
Status: assignedconfirmed
Version: 4.5.14.5.0

We found a very curious thing. If you configure editor to start in the Source mode (by using config.startupMode), then editor loads, browser refreshes the page, editor load again and then we have a total crash.

It means that this is definitely something wrong inside Edge. There's no inf loop or editor's crash – it's a browser crashing. What's more – sourcearea does not do any magic. It's a very simple plugin, so there's little we can change in it. Therefore, this issue must be fixed on Edge's side.

I'll report it later to Microsoft.

comment:12 Changed 3 years ago by Piotrek Koszuliński

Having problems updating Windows 10, I had a chance to test the same TC on an older build of Spartan, and there's no crash. What means that it's a regression in Edge.

comment:13 Changed 3 years ago by Bert Hankes

Temporary solution... use sourcedialog instead of sourcearea

see http://sdk.ckeditor.com/samples/sourcearea.html section: Classic Editor with Source Dialog

comment:14 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

A workaround has been implemented in #13609 (and included in CKEditor 4.5.2) so source are works fine now.

What worries me though is that it's 3 weeks now and Microsoft still didn't even reply to the crash report ;/.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy