Opened 3 years ago

Closed 2 years ago

#13755 closed Bug (fixed)

[Edge] Pasting images in Edge does not work

Reported by: Jonathan Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.5.11
Component: General Version: 4.5.0
Keywords: Cc:

Description

Steps to reproduce

  1. Take a screenshot so that clipboard has an image in buffer.
  2. CTRL+V to paste image in editor

Expected result

Pasting images should work when using the uploadimage plugin in Edge like it does in IE11, Chrome, and Firefox. It appears that browser does support this functionality as gmail is able to handle pasting in images from the clipboard when using MS Edge.

Actual result

Nothing pastes in.

Other details (browser, OS, CKEditor version, installed plugins)

Windows 10, Microsoft Edge with uploadimage plugin.

Change History (18)

comment:1 Changed 3 years ago by Piotrek Koszuliński

Status: newconfirmed
Summary: Pasting images in Edge does not work[Edge] Pasting images in Edge does not work
Version: 4.5.34.5.0

Microsoft did an odd thing in Edge - they dropped the old clipboard API and didn't introduce the new one yet ;/

See https://wpdev.uservoice.com/forums/257854-microsoft-edge-developer/suggestions/8964523-support-html5-drag-and-drop-of-files-from-explorer and https://dev.ckeditor.com/ticket/13595#comment:4

We need to wait until they'll resolve this issue.

comment:2 Changed 3 years ago by Jonathan

I knew it was an issue for dragging and dropping files. I'm curious how gmail is working around the issue for just pasting copied images like screen shots in the clipboard with Edge right now. There must be some API that works right now if gmail is able to do it.

comment:3 Changed 3 years ago by Piotrek Koszuliński

Curious. I'll pass this info to @pjasiun. Maybe pasting might already work in Edge.

comment:4 in reply to:  1 Changed 3 years ago by Alfonso Martínez de Lizarrondo

Replying to Reinmar:

Microsoft did an odd thing in Edge - they dropped the old clipboard API and didn't introduce the new one yet ;/

See https://wpdev.uservoice.com/forums/257854-microsoft-edge-developer/suggestions/8964523-support-html5-drag-and-drop-of-files-from-explorer and https://dev.ckeditor.com/ticket/13595#comment:4

We need to wait until they'll resolve this issue.

Don't confuse pasting with dropping files.

Pasting works correctly and you can test that http://www.martinezdelizarrondo.com/ckplugins/simpleuploads.demo4/ works without any change for Edge (it's using CKEditor 4.4.2)

and here's an updated demo with 4.5.4 just adjusted to allow dropping files in the dialogs that by default CKEditor now blocks: http://www.martinezdelizarrondo.com/ckplugins/simpleuploads.demo45/ (I need time to check if anything else is broken by your Clipboard + DnD implementation before setting this as the default demo)

comment:5 Changed 3 years ago by Jonathan

Just to clarify, the specific use case that seems like should be allowed is taking a screenshot with the PrtScn key and pasting into the editor. This does not work in Edge in the editor (on ours or the demo). This specific workflow is supported by gmail.

comment:6 Changed 3 years ago by Jonathan

The PrtScn and paste workflow does work with the demo alfonsoml provided in Edge: http://www.martinezdelizarrondo.com/ckplugins/simpleuploads.demo45/

comment:7 Changed 3 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedreview

Edge does not support pasting or dropping files, but, in fact, it supports pasting image via the new Clipboard API (evt.clipboartData.items). Because old IEs didn't support evt.clipboartData we didn't handle it in Edge too. I fixed it, changes are in t/13755. However, it may break something in old IEs, they need to be tested.

comment:8 Changed 3 years ago by Jonathan

Is this something that could be included in the 4.5.5 release?

comment:9 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.5

Assigning to the milestone so we don't forget to review it.

comment:10 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5CKEditor 4.5.6

comment:11 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:12 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

comment:13 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:14 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9CKEditor 4.5.10

comment:15 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.10CKEditor 4.5.11

Moving tickets to the next milestone.

comment:16 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.11CKEditor 4.6.1

comment:17 Changed 2 years ago by Marek Lewandowski

It does look like ClipboardEvent object comes with a DataTransfer instance under clipboardData property. The image comes as clipbaordData.items[ 0 ] as a kind = file and type = image/png. For some reason our dataTransfer instance does not pick it up.

comment:18 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.5.11
Resolution: fixed
Status: reviewclosed

Fixed with git:3f284eda6.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy