Opened 3 years ago

Last modified 3 years ago

#13922 confirmed Bug

Autogrow plugin failure to make the editable area grow properly if the zoom plugin is set to value greater than 100 %

Reported by: Edson Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Download CKeditor custom preset standard plus plugins Auto Grow and Zoom
  1. Edit ckeditor\samples\js\sample.js to include:
CKEDITOR.config.extraPlugins = 'autogrow';
CKEDITOR.config.removePlugins = 'resize';
  1. Open ckeditor\samples\index.html
  1. Click Source Code button, clear all code and paste this code:
<p>start text</p>

<p>text text text text text text text text text text text text text text text text text text</p>

<p>text text text text text text text text text text text text text text text text text text</p>

<p>text text text text text text text text text text text text text text text text text text</p>

<p>end text</p>
  1. Click Source Code button again and apply zoom grater than 100%

Expected result

See all paragraphs

Actual result

It can not see the all paragraphs

Other details (browser, OS, CKEditor version, installed plugins)

Firefox ESR 38.4.0

Attachments (3)

autogrow+zoom+100percent.png (58.9 KB) - added by Edson 3 years ago.
Auto grow + zoom 100%
autogrow+zoom+125percent.png (61.6 KB) - added by Edson 3 years ago.
Auto grow + zoom 125%
2015-11-17_1535.swf (851.7 KB) - added by Jakub Ś 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by Edson

Auto grow + zoom 100%

Changed 3 years ago by Edson

Auto grow + zoom 125%

comment:1 Changed 3 years ago by Jakub Ś

Keywords: autogrow zoom removed
Resolution: invalid
Status: newclosed
Version: 4.5.4

I was surprised there is no scrollbar but I have checked it in standard Firefox and scroll bar is there. Perhaps there is something wrong with the ESR version.

As for the "It cannot see the all paragraphs". Please not that zoom is only assigned to editor content area and not main page.

comment:2 Changed 3 years ago by Jakub Ś

Similar zoom plugn issue was also mentioned here: #13372

comment:3 Changed 3 years ago by Edson

Thanks for your answer j.swiderski. The scroll bar is set to hide when plugin Auto Grow is enabled. This is correct as you can see in http://ckeditor.com/demo#auto-grow. But when Auto Grow plugin and Zoom plugin are enabled together and zoom level is set above 100%, the autogrow doesn't work as it should. In Chrome 46.0.2490.86 and Firefox 42.0, after to apply zoom 125%, for example and to click into editor's editable area, the editable area does not grow enough to make the entire text visible in the editable area. In Internet Explorer 10.0.9200.17357 the autogrow plugin makes the editable area grow enough after zoom 125% (or above), but only just after the click into area editable.

comment:4 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

Changed 3 years ago by Jakub Ś

Attachment: 2015-11-17_1535.swf added

comment:5 Changed 3 years ago by Jakub Ś

Status: reopenedconfirmed

@edsonperotoni thank you for the follow up. Yes, you are right. There is no scroll and you can't see the whole text. I must have not checked this properly.

The problem is that zoom plugin is third-party plugin and we don't support it. I'm confirming this issue because maybe the autogrow could (as well as find plugin from #13372) support the transform: scale(N.NN);.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy