Opened 3 years ago

Closed 3 years ago

#14379 closed Bug (duplicate)

Windows Chrome > Removing Space between Words, then Re-inserting space creates unwanted non-breaking space

Reported by: Jason Malatia Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.1
Keywords: Blink Cc:

Description

Steps to reproduce

  1. Using current version of Windows Chrome. Type a phrase: Apollo 11 was the spaceflight that landed the first humans.
  1. Using the backspace or delete key remove the space between 'Apollo' and '11'
  1. Then using the spacebar, re-insert the space.
  1. CkEditor will insert an unwanted non-breaking space character ( )

Expected result

A normal space

Actual result

A non-breaking space ( )

Other details (browser, OS, CKEditor version, installed plugins)

Problem only seems to happen on Chrome browser. Tested on 2 computers both with Chrome browser Version 48.0.2564.103 m (verified problem also occurs in incognito mode). Tested on both a Windows 7 and a Windows 8.1 machine.

Firefox 44.0 & IE11 on same computer insert a normal space as expected.

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Blink added; unwanted non-breaking space nbsp backspace delete removed
Status: newconfirmed
Version: 4.5.74.4.1

This issue has been fixed in CKEditor 4.2.3 - #9929, and it has reappeared again in CKEditor 4.4.1

Problem can only be reproduced in Blink on Windows (Safari on Mac is free of this issue).

comment:2 Changed 3 years ago by Jason Malatia

Any updates on a fix? This is kinda a big problem when using ckEditor for updating things...

comment:3 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

It seems this issue is a duplicate of #11415.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy