Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14509 closed Bug (invalid)

Editor appears to remove hand-coded styles in span in Chrome

Reported by: Don Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

While in editor instance, I use the source view to add span styling to create a drop cap at the beginning of a paragraph. In Chrome, saving the contents to the database removes key parts of the style, but in Firefox, saving retains this code.

Steps to reproduce

  1. Select source view
  2. Add <span id="dropCap" style="float: left; width: 0.7em; font-size: 400%; line-height: 80%;">T</span> to first character of a paragraph.
  3. Close source view
  4. Execute save to database

Expected result

A reasonably formatted DropCap.

Actual result

In Firefox, this works well ... In Chrome, *--id="dropCap" style="float: left; width: 0.7em;--* portions get removed on save.

Other details (browser, OS, CKEditor version, installed plugins)

Chrome v49.0.26 Firefox 44.0.2

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.7

The only reason why editor might remove spans is because of ACF but this feature is not browser dependent. If this is happening in single browser and after saving data on server-side then you need to check third-party plugins installed in chrome and your server-side code. It is most likely one of those areas which is causing your problem

If you wish to learn more about ACF please see:
http://docs.ckeditor.com/#!/guide/dev_acf
http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter
http://docs.ckeditor.com/#!/guide/dev_disallowed_content
http://docs.ckeditor.com/#!/api/CKEDITOR.filter-method-addTransformations
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-allowedContent
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-extraAllowedContent

comment:2 Changed 3 years ago by Jakub Ś

#14511 was marked as duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy