Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14511 closed Bug (duplicate)

#14509 closed Bug (invalid) Editor appears to remove hand-coded styles in span in Chrome

Reported by: Don Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.7
Keywords: Cc:

Description

Closing the ticket without letting me respond is poor customer service!

Your response...

The only reason why editor might remove spans is because of ACF but this feature is not browser dependent. If this is happening in single browser and after saving data on server-side then you need to check third-party plugins installed in chrome and your server-side code. It is most likely one of those areas which is causing your problem

First, ONLY PART of the span style is removed, specifically ID, FLOAT, and WIDTH.

Second, I ALREADY verified the server-side code was not doing this by checking it BEFORE setting a ticket - I don't like wasting other's time.

Third, the fact that another browser stores the identified properties properly was a clue that Chrome and the Editor were interacting unexpectedly not the server.

And fourth, I reviewed the documents regarding ACF. During that review, I found no references to:

  1. Browser specific issues -- i.e. Chrome vs Firefox
  2. Where is the list of PROPERTIES that are initialized as "disallowed by default"? I understand that when certain buttons are not displayed in the toolbar, those TAGS are disallowed, but the text does not list how the AUTOMATIC PROPERTY DISALLOWANCES occur -- except if I engage them, and I have not done that.

While this feature is not (supposed to be) browser dependent is a nice sentiment, the challenge I am facing IS. I even went to the point of a different computer, and new install of Chrome and Firefox.

There, I confirmed that on Chrome (but not Firefox) the properties ID, FLOAT, and WIDTH are removed from the content.

SO...

  1. I have eliminated server-sides as culprit ...
  2. I have eliminated ADDONS as culprit ...
  3. I have reviewed ACF for cause and found none.
  4. AND CONFIRMED Chrome-CKeditor specific interaction.

Now, how about we try this again, instead of blowing me off.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

Closing the ticket without letting me respond is poor customer service!

Please, just comment under the ticket #14509 and don't duplicate issues. The fact that issue is closed doesn't mean that it won't get reopened. I'm sorry if this was unclear.

I will close this ticket and let's continue it in #14509.

NOTE: I have decided to close this ticket because:

  • CKEditor has nothing to do with saving data on server-side
  • The ACF which could be the only thing which might be causing this issue (I have never said it does) doesn't work in that selective manner (i.e. only on Chrome)

Questions for you to answer in ticket #14509

  1. Which CKEditor version you use?
  2. Can this issue be reproduced in default CKEditor without any core code customizations or third-party plugins (just the editor and its configuration)? If not issue may be related to that third-party code
  3. I know you have installed fresh Chrome but, please make sure it doesn't have any custom third-pary plugins installed as Chrome plugins may break JS applications.
  4. Please try using the default editor* and easiest configuration possible (try both options separately):
    var editor = CKEDITOR.replace( 'editor1', {
    	//allowedContent : true
    	extraAllowedContent : 'span{id,float,width}'
    });
    
  5. Why are you assigning Float and Width to span (and changing it into block element)? These styles should be assigned to "block-level" elements like div. There are many “default actions” performed by the editor for these elements. For example, let's say you paste below into source mode, switch to wysiwyg and then back to source
    <h1><img alt="Saturn V carrying Apollo 11" class="right" src="assets/sample.jpg" /> Apollo 11</h1>
    <div></div>
    <span id="ttt" style="float:left; width:200px;"></span>
    

Result is that h1 and div will stay while span will be removed. You should really avoid it.

NOTE: I have tried configuration mentioned in point 4 and it works well with default editor. At the moment I don't see any problem with the editor. There is most likely something in your customized version. Please try the default and if it works there, please try adding your custom features on by one to see which one breaks the editor.

Last edited 3 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy