Opened 4 years ago

Last modified 3 years ago

#14622 confirmed Bug

Borders lost when pasting from libre office calc from Chrome Windows - config.allowedContent off or with ACF filters

Reported by: jprado Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Cc:

Description

Steps to reproduce

  1. open attached table.ods, select the table and copy to clipboard
  2. paste into CKeditor content on provided html template
  3. compare result to old attached image

Expected result

Table with same styles and black borders should appear just like on LibreOffice Calc.

Actual result

Borders are not defined. Style tags are being filtered out even though allowedContent has them enabled. allowedContent=true does not work either. The result started happening on 4.5.0. Version 4.4.8 is not affected.

Other details (browser, OS, CKEditor version, installed plugins)

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36 No installed chrome plugins

Attachments (3)

table.ods (7.7 KB) - added by jprado 4 years ago.
2016-05-04_1559.png (25.1 KB) - added by jprado 4 years ago.
test.html (1.1 KB) - added by jprado 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by jprado

Attachment: table.ods added

Changed 4 years ago by jprado

Attachment: 2016-05-04_1559.png added

Changed 4 years ago by jprado

Attachment: test.html added

comment:1 Changed 4 years ago by Jakub Ś

Keywords: allowedContent ACF removed
Status: newconfirmed

We do not support LibreOffice. I can't however deny the fact that it has worked until version 4.5.0 so I tend to confirm this issue and add it to the larger set of problems which were introduced in CKE 4.5.0 and concern various pasting issues.

comment:2 Changed 4 years ago by Jakub Ś

It turns out we have quite a few issues with pasting and they all may be related as they all can be reproduced from 4.5.0:
Styles Stripping: #13860, #13926, #14250, #14358
Styles stripping on Chrome in various test cases: #14921, #14593, #13753, #13751, #16454
ForcePasteAsPlainText pastes formatted HTML with Ctrl+V: #13969
Weird event pasting relation (not sure): #13763
White spaces not preserved: #14614
Problem with pasting in LibreOffice: #14622 (we do not support it but I have added this issue because general solution might also bring back old behaviour).

Last edited 3 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy