Opened 12 years ago

Closed 7 years ago

#1476 closed Bug (wontfix)

[Firefox] Deselecting by mouse click inside of selection does not trigger GetState function of buttons.

Reported by: D_mISi Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Firefox Cc:

Description

When someone selects a part of the document in the editing area and clicks with the mouse in the middle of it, it does not trigger the GetState functions of the buttons of the toolbar. The bug is present in the "nightly build" both under Firefox 2.0.0.8 and Explorer 6.0.2900.2180... (Explorer triggers correctly sometimes - don't know why)

Reproduction (eg. with the default sample text of FCKeditor): -Click in the editing area and select the whole sentence by mouse or Ctrl-A -Click in the middle of the word "sample" (which should be in bold):

This is some sam<click here>ple text. You are using FCKeditor.

-Selection will collapse and the cursor will be "...sam<here>ple text..." but the button of 'bold' WILL NOT BE SET to FCK_TRISTATE_ON.

-On the other hand, if you select something and click outside of it, eg:

<select from here>This is<to here> some sample text. You are using FCKeditor.

-Click in the middle of the word "sample" (this should be in bold and outside of the current selection):

This is some sam<click here>ple text. You are using FCKeditor.

-Selection will collapse and the cursor will be "...sam<here>ple text..." and button "B" WILL BE SET to FCK_TRISTATE_ON.

Change History (3)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox added
Summary: Deselecting by mouse click inside of selection does not trigger GetState function of buttons.[Firefox] Deselecting by mouse click inside of selection does not trigger GetState function of buttons.
Version: SVN

Confirmed only in Firefox using the latest SVN.

In IE everything works fine.

comment:2 Changed 8 years ago by Krzysztof Studnik

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy