Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14791 closed Bug (duplicate)

Link plugin links both the word and space following it when you double click on a word and hyperlink it

Reported by: Praveen Jeyaraj Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Ensure you have the http://ckeditor.com/addon/link plugin
  2. Insert a line with few words
  3. Double click on some word in the middle of the line - it will select the word and the space following it
  4. Click on the link button to hyperlink the word

Expected result

  1. It should only hyperlink the word (e.g. MS Word behavior) without including the space following the word in the linked text

Actual result

  1. However currently it links the word and the space following it. As a result, when the word is subsequently deleted without deleting the space following it, it leaves behind a link on the empty space which can cause other undesired downstream impact

Other details (browser, OS, CKEditor version, installed plugins)

Link plugin: http://ckeditor.com/addon/link - you can check out this behavior on the link widget page itself.

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: link removed
Resolution: duplicate
Status: newclosed
Version: 4.5.10 (GitHub - master)

I agree, this should work like in MS Word and white space should be trimmed.

I will however close this ticket as a duplicate of #8690 because it point outs more scenarios.

comment:2 in reply to:  1 Changed 3 years ago by Praveen Jeyaraj

Ok thanks for looking into this. Hoping for #8690 to be fixed in the next CKE release.

Replying to j.swiderski:

I agree, this should work like in MS Word and white space should be trimmed.

I will however close this ticket as a duplicate of #8690 because it point outs more scenarios.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy