Opened 3 years ago

Closed 3 years ago

#16393 closed Bug (fixed)

[Moono-lisa] Toolbar is broken when a row is too long

Reported by: Wiktor Walc Owned by: kkrzton
Priority: Normal Milestone: CKEditor 4.6.0
Component: UI : Skins Version: 4.6.0
Keywords: Cc:

Description (last modified by Wiktor Walc)

Steps to reproduce

  1. Create a relatively long single-row toolbar.
  2. Load a sample in a browser.
  3. Reduce the width of the window so that the single-row toolbar was split into two rows.

Expected result

Buttons in the second row start on the left side. See moono below:

Actual result

Buttons in the second row start after the last dropdown list.

Note: I do not care that dropdowns have now different width than in moono, for me that's not a problem, I even prefer it.

Attachments (2)

moonolisa.png (11.3 KB) - added by Wiktor Walc 3 years ago.
moono.png (17.5 KB) - added by Wiktor Walc 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by Wiktor Walc

Attachment: moonolisa.png added

Changed 3 years ago by Wiktor Walc

Attachment: moono.png added

comment:1 Changed 3 years ago by Wiktor Walc

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedreview

This bug was caused by the fact that dropdowns were 1px higher than the rest of the buttons and in this particular case it pushed second row to the right. All buttons/dropdown should have same height.

Fixed with t/16393.

comment:3 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

Interestingly it was happening only with particular button orders. I've added a manual test for this so it's easy to verify.

Fixed with git:fafbb08f1a6b3959079553802710ce26882015d9, merged to major.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy