Opened 11 years ago

Closed 5 years ago

#1653 closed Bug (fixed)

span colors switching from HEX to RGB

Reported by: rud Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Confirmed Cc: Frederico Caldeira Knabben, Garry Yao

Description

While working on my editor settings today, i accidentaly noticed my flash movie wasn't loading colors anymore .. after checking the xml i was loading (which is fckeditor generated), i noticed all the <span> blocks are now using RGB instead of HEX colors ..

Now i'm almost sure this is not related to my settings. I've even disabled my custom config file (and triple emptied cache), but still, i get RGB instead of HEX when i select a peace of text, and apply a color from the color panel.

Attachments (1)

1653.patch (5.3 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Proposed patch

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by amerigo5

This bug dramatically affects the HTML source by simply updating a HTML text using IE and FireFox. If the HTML source is created in IE, the color uses hexadecimal and when the same HTML source is updated using FireFox, suddenly all the color style gets converted to RGB. Can the priority of this bug be increased?

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; colors hex rgb removed
Priority: LowNormal

Confirmed

comment:3 Changed 11 years ago by Martin Kou

Milestone: FCKeditor 2.7
Version: FCKeditor 2.5SVN

Firefox seems to have a tendency to turn color related CSS attributes to RGB format automagically, which was observed in the ticket #617 as well. It seems color related CSS attributes will need to be protected to properly fix this issue.

Since #617 is targeted to 2.7, I'm targeting this related ticket to 2.7 as well.

comment:4 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.3
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned
Version: SVN (FCKeditor)3.0

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 1653.patch added

Proposed patch

comment:5 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Cc: Frederico Caldeira Knabben Garry Yao added
Keywords: Review? added

While trying to fix this issue I've found that the css normalization isn't applied to the output data, so for example #1709 and #2929 aren't really fixed.

So in the patch I moved the normalizeCssText to CKEDITOR.tools, and the replacements at the end of the function have been adjusted so it properly cleans whitespace and removes the trailing semi colon.

This will help with the issues related to styles and marked as dups of #1810, but of course it will mean a slight penalty in performance, although I don't think that it will be something that can be noticed.

comment:6 Changed 9 years ago by Garry Yao

Keywords: Review- added; Review? removed

This feature has to be configurable and delivered by htmlDataProcessor plugin instead of the core codes.

comment:7 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.3CKEditor 3.4

Let's handle this in 3.4 combined with #5528 to avoid performance problems.

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4

comment:9 Changed 8 years ago by Wiktor Walc

#6638 was marked as duplicate.

comment:10 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_failedclosed

This issue was fixed long time ago.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy