Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16758 closed Bug (duplicate)

The underline is not of the selected colour when Underline icon (U - icon in toolbar) is selected later

Reported by: Imamudin Naseem Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

Steps to reproduce

Steps to reproduce :

  1. Write some text and color it blue.
  2. Now , underline it.

Expected result

The underline color should be blue.

Actual result

The underline color is black

Other details (browser, OS, CKEditor version, installed plugins)

Note: On the other hand, if the underlined text is already selected and then colored, it is works as expected.

Attachments (1)

underline Bug.png (61.4 KB) - added by Imamudin Naseem 3 years ago.
snapshot

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Imamudin Naseem

Attachment: underline Bug.png added

snapshot

comment:1 Changed 3 years ago by Imamudin Naseem

Another usecase:

While selecting the underlined text and then selecting a colour for it changes the "underline and the text" both to that colour. But while selecting the underline option and colour and then writing the text , changes only the text to that colour and not the underline. Underline remains black.

comment:2 Changed 3 years ago by Tade0

Status: newconfirmed
Version: 4.6.14.0

comment:3 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is actually a duplicate of #5503.

comment:4 Changed 3 years ago by Imamudin Naseem

IMHO this can not be a duplicate of #5503. #5503 is regarding background-color size not getting increased by increasing font-size but this ticket is regarding color of underline color being different from text color.

comment:5 Changed 3 years ago by Imamudin Naseem

I am not able to modify the state of this bug. Please make necessary changes.

comment:6 Changed 3 years ago by Jakub Ś

Both tags are about the order of tags or about styles which are not merged. THis is a duplicate.

On the other hand, if the underlined text is already selected and then colored, it is works as expected.

You have noticed it as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy