Opened 9 months ago

#16859 new Bug

Not able to Assign Table Elements Contents To CKEDITOR at RunTime

Reported by: Vijay M R Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 4.7.0
Keywords: Cc:

Description

Below is My CsHtml File

<div id="kendorte-@entityId" class="rte-editor">

@*@Html.TextArea("editorplace", new { @id = "editor1" ,@class="inline-editor ms-rtestate-write"})*@ <textarea @*class="inline-editor ms-rtestate-write"*@

class="ckeditor" id="editor-@entityId" @*id="editor1"*@ data-entity-id="@entityId" data-entity-qavid="@qavId" data-iscore-attr="@Model.IsCore" data-connect-coreid="@Model.ConnectCorePriorityId">

@{

var data = Html.Raw(Model.Text); }

</textarea>

<script src="../../content/ckeditor/ckeditor.js"></script> @*<script src="../../content/ckeditor/samples/js/sample.js"></script>*@ <script>

callckeditor('editor-@entityId', @isCP,@data);

</script>

</div>

callckeditor is a function

callckeditor(objectid,iscp,textcontent) { CKEDITOR.document.getById('editor-@entityId').setHtml('@data'); }

The problem is i am not able to Load the Table related data on TextEditor

The Content is <table style="width:100%">

<tr>

<th>Firstname</th> <th>Lastname</th> <th>Age</th>

</tr> <tr>

<td>Jill</td> <td>Smith</td> <td>50</td>

</tr> <tr>

<td>Eve</td> <td>Jackson</td> <td>94</td>

</tr>

</table>

Other details (browser, OS, CKEditor version, installed plugins)

latest CKeditor Version

Change History (0)

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy