Opened 11 years ago

Closed 6 years ago

#188 closed Bug (fixed)

z-index of Image in editor prevents toolbar action

Reported by: johnv@… Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version:
Keywords: IBM SF IE Cc: satya_minnekanti@…

Description

Steps:

  1. Add image to the Editor.
  2. Resize if necessary so that height and width extend beyond editor input.
  3. Use scroll bar so that top image size handles overlay the toolbar icons.
  4. Click any toolbar icon.

You will see that nothing happens. I've tried to change the z-index, but inline styles are removed or replaced in editor (i.e. when toggling between design and html mode).

Thanks!


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1589572&group_id=75348&atid=543653

Attachments (4)

188.patch (3.6 KB) - added by Frederico Caldeira Knabben 6 years ago.
188_2.patch (1.1 KB) - added by Garry Yao 6 years ago.
188_3.patch (3.6 KB) - added by Frederico Caldeira Knabben 6 years ago.
188_4.patch (3.7 KB) - added by Frederico Caldeira Knabben 6 years ago.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

https://sourceforge.net/tracker/index.php?func=detail&aid=1662158&group_id=75348&atid=543653 has been marked as dup.


Moved from SF. Original poster: alfonsoml

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Reporter: changed from Frederico Caldeira Knabben to johnv@…

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: IE Confirmed CantFix added
Resolution: wontfix
Status: newclosed

Confirmed with IE6 and IE7. Firefox is ok.

I don't believe we have something to do here. This is a IE behavior "by design" (like they like to call their bugs). It probably adds a transparent object over the image that caches mouse click events. This is why we also see the image handles outside the editor area.

Maybe IE8 will fix it?

I'm not that optimist. To make it happen we should first of all make MS note that someone cares about it. But their "Feedback" site is closed, at least right now:
https://connect.microsoft.com/IE

Maybe we'll have some lucky in the near future.

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

#4722 has been marked as DUP.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

#4055 has been marked as DUP.

comment:6 Changed 8 years ago by Alfonso Martínez de Lizarrondo

#4986 has been marked as dup

comment:7 Changed 7 years ago by Alfonso Martínez de Lizarrondo

#5963 has been marked as dup

comment:9 Changed 6 years ago by Garry Yao

Affects also float panel, where #7586 is marked as a DUP.

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 188.patch added

comment:10 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: closedreopened

Just came to my mind an idea that seems to workaround this issue. We can use "onmouseup", instead of "onclick".

The drawback is that it will fire the button if we move the mouse over the toolbar and "mouse up". This doesn't look like a huge problem though and it's a good compromise to have this important issue finally fixed.

The patch includes fixes to "listblock" and "menu" because of #7586.

comment:11 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: reopenedreview

Changed 6 years ago by Garry Yao

Attachment: 188_2.patch added

comment:12 Changed 6 years ago by Garry Yao

Status: reviewreview_failed

Without considering other things the attached patch should be just enough to make it work.

comment:13 Changed 6 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:14 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: Confirmed removed
Status: review_failedreview

I've checked your patch, but it brings back several issues related to toolbar elements that are selectable and draggable.

I would ask to please re-consider the first patch.

comment:15 Changed 6 years ago by Garry Yao

Status: reviewreview_passed

comment:16 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [6971].

comment:17 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:18 Changed 6 years ago by Alfonso Martínez de Lizarrondo

The patch has introduced #8007

comment:19 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

I've reverted [6971] with [7027] because of #8007.

comment:20 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 188_3.patch added

comment:21 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1
Status: reopenedreview

The difference with this new patch is that it simply cancels the onclick event as well (on IE), which seems to be enough to avoid #8007.

Curiously, canceling onclick is necessary for the button code only.

comment:22 Changed 6 years ago by Garry Yao

Status: reviewreview_failed

Rich combo is still affected by tc @ #8007

comment:23 Changed 6 years ago by Wiktor Walc

It looks like combo elements are losing their white background in IE8/Quirks and IE6 with this patch (it also happened with the patch that was reverted).

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 188_4.patch added

comment:24 Changed 6 years ago by Frederico Caldeira Knabben

Status: review_failedreview

Just in case, to avoid other unknown IE quirks, I'm cancelling the onclick event on the other changed parts of the code as well. It fixed #8007 for the combos and fortunately fixed the background issue as well.

comment:25 Changed 6 years ago by Garry Yao

Keywords: CantFix removed
Status: reviewreview_passed

...and fortunately fixed the background issue as well.

Are you pointing to #4029, I saw no relationship with the patch here, and I can still reproduce that issue with zh-cn language code.

comment:26 in reply to:  25 Changed 6 years ago by Frederico Caldeira Knabben

Replying to garry.yao:

...and fortunately fixed the background issue as well.

Are you pointing to #4029, I saw no relationship with the patch here, and I can still reproduce that issue with zh-cn language code.

No, sorry for not been clearer. It was about comment:23, which is a little bit different. But in fact that comment doesn't have enough details to be properly understood. Wiktor gave me the details with Skype.

The problem was that the background of the combos was disappearing *when clicking on them*. #4029 says that it is always removed, no matter what.

comment:27 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [7036].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy