Ticket #2103 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

[FF] Unstable editing with blockquote and formatted text

Reported by: geirhelge Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: Firefox Cc:

Description (last modified by martinkou) (diff)

We're having a problem when using blockquote and formatted text. After we've been writing a couple of paragraphs and starts to edit the text, line breaks are removed where it shouldn't and wrong characters are removed. I'm reporting this in the same bug since it might be just two ways to reproduce the same bug.

Both examples are reproduced in version 2.5.1 and 2.6 with Firefox 2.0.0.13 on Ubuntu and Windows XP. I've not been able to reproduce the bug in IE 6 or 7.

Line breaks that are removed How to reproduce:

  1. Click blockquote and select format "formatted"
  2. Type
    a
    a
    a
    
  3. Hit enter two times creating a paragraph
  4. Type
    b
    b
    b
    
  5. Hit enter two times creating a paragraph
  6. Type
    c
    c
    c
    
  7. Hit CTRL+Z, hit enter once and type
    c
    
  8. Move the cursor in front of the last b
  9. Hit backspace

The last b is placed after the second b, that's good, but at the same time the last c is placed after the second c.

Wrong character deleted

  1. Click blockquote and select format "formatted"
  2. type "asdf" hit enter two times and type "hjkl"
  3. Move the marker at the beginning of the line with "hjkl"
  4. Hit backspace two times in order to move "hjkl" on the same line as "asdf"

Result: One hit on backspace removes the empty line, the next removes the "f" and if you continue the whole line with "asdf" will be deleted.

What I'd expected: The string "hjkl" to be moved at the end of "asdf"

Change History

comment:1 Changed 6 years ago by geirhelge

Ah, all my line breaks was removed in the report :(

The editor content should look like this before hitting CTRL+Z:
a
a
a

b
b
b

c
c
c


It's important that you use undo and retype the last c before trying to remove the line break between the second and the third b.

comment:2 Changed 6 years ago by martinkou

  • Description modified (diff)

Tidied up the description.

comment:3 Changed 6 years ago by w.olchawa

  • Keywords Confirmed Firefox added
  • Summary changed from Unstable editing with blockquote and formatted text to [FF] Unstable editing with blockquote and formatted text

Confirmed in FF2 using FCKeditor 2.6 and SVN. Works OK in IE.

comment:4 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy