Opened 11 years ago

Closed 8 years ago

#2148 closed Bug (worksforme)

Image losing selection in IE after opening the image dialog.

Reported by: Martin Kou Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: IE Cc:

Description

Reproduction procedure:

  1. Open sample07.html.
  2. Paste the following HTML in Source Mode:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
        <head>
            <title>Full Page Test</title>
            <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><style type="text/css">
    #Gallery {
    	width: 500px;
    }</style>
        </head>
        <body>
            <div id="Gallery"><img height="240" alt="" width="240" src="a.jpg" /><img height="240" alt="" width="240" src="b.jpg" /></div>
        </body>
    </html>
    
  3. Switch back to WYSIWYG mode.
  4. Right click on one of the images, choose "Image Properties".
  5. Close the Image Properties dialog
  6. The selection to the image is lost.

This bug happens on IE only.

Change History (3)

comment:1 Changed 11 years ago by Martin Kou

The bug also occurs when a height CSS attribute is defined in #Gallery.

comment:2 Changed 11 years ago by Alfonso Martínez de Lizarrondo

The problem might be the same than #798, and maybe even #2166 could be fixed at the same time.

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy