Opened 12 years ago

Closed 6 years ago

#2177 closed Bug (fixed)

Inserting special characters inside some inline tags in Firefox incorrectly splits the inline tag into two

Reported by: Martin Kou Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox Cc:

Description

To reproduce the problem:

  1. Open sample01.html in Firefox 2 or 3.
  2. Place the caret inside the bolded "sample text" in the editing area.
  3. Insert a special character via the Special Character dialog.
  4. Something is wrong: the special character inserted is not bold.
  5. Switch to Source mode.
  6. The <strong> tag in the HTML code is split into two, with the special character in between them. This is not correct.

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

This issue is caused by a Gecko browser bug, I've filed a bug report to https://bugzilla.mozilla.org/show_bug.cgi?id=432587.

comment:2 in reply to:  1 Changed 8 years ago by Krzysztof Studnik

Version: SVN (FCKeditor) - Retired3.0

Replying to martinkou:

This issue is caused by a Gecko browser bug, I've filed a bug report to https://bugzilla.mozilla.org/show_bug.cgi?id=432587.

Which was set as invalid.

In CKE3.6.2, under FF, result of above TC is:

<p>
	This is some <strong>samp</strong><strong>&reg;</strong><strong>le text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>

See that <strong> is split into 3 parts.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

We no longer use native insertHTML command, so this issue expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy