Opened 11 years ago

Closed 8 years ago

#2179 closed Bug (worksforme)

Identical adjacent styles are not merged

Reported by: Hervé BLONDEAU Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.5
Keywords: Cc:

Description

ENVIRONMENT
This was tested with the following browsers:

  • Windows XP: Firefox2
  • MacOS X: Safari3

And with FCKeditor 2.5 and 2.6

DESCRIPTION

  1. Using any of the aforementioned browsers/OS, go to the demo page at http://www.fckeditor.net/demo
  2. Apply an inline style such as "Marker: Yellow" to "This is so" at the beginning of the line
  3. Apply the same style to "me sample text"

The generated source is:

<span style="background-color: Yellow;">This is so</span><span style="background-color: Yellow;">me <strong>sample text</strong></span>


But it would make more sense to merge the tags and output (as it is done in IE):

<span style="background-color: Yellow;">This is some <strong>sample text</strong></span>



This is obviously in the same category as ticket #2040, however I did not know if it can be considered as a duplicate and therefore created a new ticket.

Change History (2)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

Confirmed using FCKeditor 2.6 and the current SVN in:

  • Firefox 2.0.0.14 / Windows XP Professional
  • Safari 3.1 / Windows XP Professional

IE doesn't seem to be affected.

comment:2 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy