Opened 12 years ago

Closed 12 years ago

#2219 closed Bug (invalid)

Background-image and width problems in IE when using custom stylesheet (EditorAreaCSS)

Reported by: Priet Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending Cc:

Description

As mentioned here: EditorAreaCSS: HTML- and body-tags not working in IE? I've found a problem when using EditorAreaCSS in IE:

  • Background-image for HTML and Body don't work when using them both
  • width is ignored

The background-image for the HTML or BODY tags do work, but not if you use them both.

The width property for HTML and BODY is ignored: IE always shows the lines (i.e. paragraphs over the full length of the editor).

Two screenshots:

I've prepared a test page to see it:

I've installed the IE Developer Toolbar. With that tool I saw that the HTML and BODY tag did had a width property, but the problem was still there.

The background-image is not the worst problem: not being able to set the width is very annoying for the editors using FCKEditor.

What's causing this and how to fix this?

Attachments (2)

fckeditor_css_wrong.jpg (71.6 KB) - added by Priet 12 years ago.
fckeditor_css_good.2.jpg (96.5 KB) - added by Priet 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Priet

Attachment: fckeditor_css_wrong.jpg added

Changed 12 years ago by Priet

Attachment: fckeditor_css_good.2.jpg added

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending added

Do you have better results by setting the DocType setting in fckconfig.js to the XHTML 1.0 Transitional doctype?

Remember to clean up your browser cache.

comment:2 in reply to:  1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Replying to fredck:

Do you have better results by setting the DocType setting in fckconfig.js to the XHTML 1.0 Transitional doctype?

Remember to clean up your browser cache.

Unless he tests with a nightly (that he should have done before filing the bug), the doctype won't matter due to #2102

comment:3 Changed 12 years ago by Priet

Thanks for the DocType tip: that was the cause of the problem.

As mentioned by alfonsoml, I had to use a nightly build to set the DocType to XHTML. Strangely enough, the old HTML 4.01 transtional doctype didn't work anymore.

But with the XHTML DocType all problems are gone :)

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy