Ticket #2251 (closed Bug: duplicate)

Opened 6 years ago

Last modified 6 months ago

FCKeditor assumes default colours

Reported by: malvineous Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

If you change the default colours in your web browser, the FCKeditor formatting "breaks", and can become unreadable.

For example if you change your default web browser colours to a dark blue background, bright yellow text and bright cyan links, then when you use FCKeditor (and indeed browse the FCKeditor homepage) the text is bright yellow on a white background, becoming virtually unreadable.

The problem is that in many places the background colour is changed, but the foreground colour is not changed at the same time (assuming it will always be black, which it may not.) Whenever the background colour is changed, the foreground colour should also be changed otherwise it could easily clash with the new background colour, given that the default colours are user-dependent. Likewise whenever the foreground colour is changed the background colour should also be changed (although this is less of a problem.)

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Pending added

Could you please let us know what are your reasons for changing the default browser colours? Usually user don't overwrite those colours because their affect on web pages are to big e.g. overwriting css colours.

Thanks in advance.

comment:2 Changed 6 years ago by malvineous

The default black-on-white is too bright for me, I find yellow-on-dark-blue much easier to read. There is an option to stop web pages from changing the colour at all, but I don't use that - I only change the default colours used when the web pages doesn't set a colour themselves.

The problem is that your CSS assumes the default text colour will be black when it may not be - all you need to do is add "color: black;" into the CSS each time you change the background colour and the problem will be solved.

comment:3 Changed 6 years ago by alfonsoml

  • Keywords Confirmed added; Pending removed

Of course the user should be able to set whatever colors they like, and if we want to use a foreground or background-color, then we should provide also the other color so it doesn't fail as it's reported.

I guess that there are several places where this change must be done, can you provide a list of suggested changes?

Thanks.

comment:4 Changed 6 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

I think this ticket can be considered a duplicate of #1601.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy