Opened 9 years ago

Closed 9 years ago

#2252 closed New Feature (fixed)

Setting to disable our custom menu

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

There should be a configurable way to not use our custom context menu at all, leaving the default browser context menu to work.

The solution is already proposed at #311. I think the "BrowserContextMenu" setting name is better because it follows the already present "BrowserContextMenuOnCtrl" name.

Attachments (2)

2252.patch (3.0 KB) - added by Wojciech Olchawa 9 years ago.
2252_2.patch (2.6 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by Alfonso Martínez de Lizarrondo

instead of adding another setting we could fix #1683 instead and get the same end result.

Changed 9 years ago by Wojciech Olchawa

Attachment: 2252.patch added

comment:2 Changed 9 years ago by Wojciech Olchawa

Keywords: Review? added

comment:3 in reply to:  1 Changed 9 years ago by Frederico Caldeira Knabben

Replying to alfonsoml:

instead of adding another setting we could fix #1683 instead and get the same end result.

A dedicated setting for it, other than making it much simpler (to configure an to implement), sounds like a much more evident solution for this need.

#1683 sounds a bit ambiguous... what should happen if you right click on the text, and you have only "Image" in the ContextMenu setting? Should it display the browser context menu or nothing?

comment:4 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Martin Kou

Keywords: Review- added; Review+ removed

Unfortunately, I have to reverse my Review+ because of some potential problems in the patch.

First problem... the patch causes the browser menu to appear automagically if the user upgraded from a previous FCKeditor version's fckconfig.js - FCKConfig.BrowserContextMenu == false evaluates to false when the option is undefined.

Second problem... the current approach doesn't allow the setting to be changed after FCKeditor has loaded. It might be better if the check is implemented at the context menu/click event handler, instead of at load time.

Much thanks to Alfonso for reporting these problems to me in the IRC channel.

comment:6 Changed 9 years ago by Martin Kou

Owner: changed from Wojciech Olchawa to Martin Kou

comment:7 Changed 9 years ago by Martin Kou

Status: newassigned

Changed 9 years ago by Martin Kou

Attachment: 2252_2.patch added

comment:8 Changed 9 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:9 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Btw, please move the changelog entry to the "New Features" block before committing.

comment:11 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2221].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy