Opened 11 years ago

Closed 8 years ago

#2304 closed Bug (worksforme)

JavaScript error in Replace dialog

Reported by: Martin Kou Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Firefox Cc: Davey Shafik

Description

To reproduce the bug:

  1. Open sample01.html in Firefox.
  2. Switch to source mode.
  3. Paste the following HTML into FCKeditor:
    <h3>Faculty and Fields of Interest</h3>
    <p><b>Bisagni, James J</b> Professor of Physics and Marine Science   and Technology (1997<span><span>&nbsp;</span>)</span><span>&nbsp;</span>, BS 1972   University of New York at Stony Brook, MS 1976, PhD 1991   University of Rhode Island Graduate School of Oceanography.   <i>Specializations:</i> Physical oceanography, satellite   oceanography.</p>
    <p><b>Crawford, Renate</b> (Chairperson, Department of Physics)   Associate Professor of Physics (1996), BS 1990, MA 1991, PhD 1993   Kent State University. <i>Specializations:</i> Experimental   liquid crystals, condensed matter, physics education and   outreach.</p>
    <p><b>Gangopadhyay, Avijit</b> Associate Professor of Physics and   Marine Science and Technology (1997), BTech 1979 Indian Institute   of Technology, Kharagpur, MTech 1982 Indian Institute of   Technology, New Delhi, PhD 1990 University of Rhode Island.   <i>Specializations:</i> Physical oceanography, numerical   modeling, climate studies.</p>
    <p><b>Hirshfeld, Alan</b> Professor of Physics (1978), BA 1973   Princeton University, MS 1975, PhD 1978 Yale University.   <i>Specializations:</i> Astrophysics, observational astronomy.</p>
    <p><b>Horch, Elliott</b> (Graduate Program Director) Assistant   Professor of Physics (2002), BA 1987 University of Chicago, MS   1989 Yale University, PhD 1994 Stanford University.   <i>Specializations:</i> Observational astronomy, astrophysics,   astronomical imaging systems.<br />
    <br />
    <b>Hsu, Jong-Ping</b> Chancellor Professor of Physics (1978), BS   1962 National Taiwan University, MS 1965 National Tsing-Hwa   University, PhD 1969 University of Rochester.   <i>Specializations:</i> Symmetry principles and gauge field   theories. <b><br />
    </b><b><br />
    Gaurav Khanna</b> Assistant Professor of Physics (2003), BTech   1995 Indian Institute of Technology, PhD 2003 Penn State   University. <i>Specializations:</i> Theoretical and computational   astrophysics, black hole astrophysics, gravitational waves,   quantum gravity, high performance computing, control and   dynamical system theory.</p>
    <p><b>O&rsquo;Reilly, Grant</b> Assistant Professor of Physics   (2002), BS 1986 University of Melbourne, PhD 1997 University of   Melbourne. <i>Specializations:</i> Photonuclear physics at   intermediate energies, few-body systems, pion photo productions,   fundamental nuclear symmetries.<br />
    <br />
    <b>Tandon, Amit</b> Associate Professor of Physics and Marine   Science and technology (1999), BTech 1987 Indian Institute of   Technology, PhD 1992 Cornell University. <i>Specializations:</i>   Fluid dynamics, physical oceanography, environmental and   computational physics.</p>
    <p><b>Wang, Jay (Jianyi)</b> Associate Professor of Physics (1998),   BSc 1983 Lanzhou University, China, PhD 1992 University of   Tennessee, Knoxville. <i>Specializations:</i> Theory and   simulations of electronic, atomic and optical processes,   ion-solids and ion-surface interactions, computational physics.</p>
    <p><b>Zarrillo, Marguerite</b> Associate Professor of Physics   (1998), BS 1978 Purdue University, MS 1981 University of   Illinois, PhD 1998 University of Central Florida.   <i>Specializations:</i> Traffic flow modeling, intelligent   transportation systems, highway capacity.<br />
    <br />
    The Physics Master of Science program is open to full-time as   well as part-time students who are planning to pursue careers in   physics research or teaching, or in applied areas of industrial   research and development. The part-time option is attractive for   students who are already professionally active as physics   teachers. In addition, the university offers an international   exchange program for a year of study abroad at universities in   Baden-W&uuml;rttemberg in Germany.</p>
    <p>The program is designed to advance students&rsquo; understanding   of the concepts of modern and classical physics as well as their   mastery of applying these concepts to solve practical problems.   Under the guidance of a graduate advisor, all students follow a   course of study that is in harmony with their background and   individual goals. The size of the fosters close and informal   contact between students and faculty active in research. These   personal contacts enable graduate students to keep abreast of   current problems in physics and offers them the opportunity to   participate in original research.</p>
    <p>The Physics Department offers a range of graduate courses in   classical mechanics, electrodynamics, quantum mechanics, physical   oceanography, condensed matter physics, and advanced mathematical   physics. The department also offers courses emphasizing research   including thesis research as well as independent study courses on   special topics. There is also advanced laboratory instruction in   experimental techniques, including electronic instrumentation,   computer interfacing and data analysis. Graduate students are   encouraged to participate in ongoing faculty research program s   in theoretical physics, physical oceanography, optics, liquid   crystals, and astronomy. In addition, research projects in   physics education are available for students pursuing a teaching   career. Students interested in applied areas of physics or in   closely related fields such as computer science or electrical and   computer engineering can take graduate courses and obtain   research projects in those areas as well.</p>
    <p>The physics background and expertise acquired by students at   UMass Dartmouth has enabled many to continue their studies at   premier research universities in the US and abroad. Others have   embarked on careers in teaching or in applied areas like nuclear   power, communications, materials science, computer or electrical   engineering, and computer software.</p>
    <p>Careers of our graduates as professional physicists are   remarkably broad in scope. The majority of physics students who   obtained their MS degree at UMass Dartmouth in recent years have   continued their studies at the Ph.D. level at other universities   including Brandeis, City University of New York at Brooklyn,   Illinois, Johns Hopkins, Kentucky, Maryland, MIT., Notre Dame,   Ohio State, Penn State, Purdue, Rensselaer, Rice, Rutgers, State   University of New York at Stony Brook and Wesleyan. Our graduates   are employed at computer software companies, high schools,   industrial concerns, national laboratories, nuclear power plants   and universities. They work in fields as varied as astrophysics,   biophysics, computer programming, electrical engineering,   experimental high energy physics, liquid crystals, materials   science, mathematical statistics, nuclear engineering, nuclear   theory and satellite communications.</p>
    <h3>Faculty and Student Research</h3>
    <p>Research activities in the Physics Department span a very diverse   range within the field, but may be grouped into three main focus   areas: Ocean Physics, Computational and Theoretical Physics, and   Experimental Physics. Student participation is highly valued in   all of these&nbsp; areas, and opportunities include research   assistantships and summer internships along with tuition waivers.   Current research efforts in the department are supported by   grants from several federal agencies.<br />
    <br />
    The world&rsquo;s oceans play a critical role in modulating both   weather and climate. Current research projects in Ocean Physics   cover physical scales from micrometers to thousands of kilometers   using several different techniques. Satellite-derived data is   used to study a variety of physical and physical-biological   interactions concerning the relationship between ocean   circulation and plankton. Numerical and analytical techniques are   used&nbsp; to study many different aspects of both coastal and   open ocean circulation, as well as upper ocean conditions and   circulation. Specific projects include studies of feature   oriented regional modeling systems and multivariate&nbsp;   synthesis of biophysical data sets in different world oceans,   biophysical modeling in the northern Humboldt Current,   basin-scale simulations of the North Atlantic, upper-ocean mixing   in the North Atlantic and Southern Ocean, interaction of   mesoscale eddies with mixed layers, ageostrophic circulation near   fronts in the upper ocean, and experimental fluid physics.   Research is carried out at both the UMass Dartmouth main campus   in North Dartmouth and the UMass Dartmouth Marine Campus located   on Clark Cove in southern New Bedford, and conducted in   collaboration with a variety of both national and international   researchers located at other federal laboratories and major   universities.</p>
    <p>Theoretical and computational research is pursued in a number of   areas. Atomic, molecular and optical (AMO) physics research   focuses on electronic and optical properties of matter in   interaction with charged particles, photons and laser pulses.   Electron correlation effects and exotic properties of Rydberg   atoms and molecules are areas of current interest. Research in   gravitational physics is also represented in the theory area in   several projects. One of the most significant of these involves   studying the coalescence of binary black holes using perturbation   theory and estimating properties of the gravitational waves   produced in this process. This research is relevant to the   various gravity wave observatories being constructed (e.g. LIGO,   LISA) that will soon detect this radiation from astrophysical   sources. Other areas of faculty interest in theoretical research   include studies of the broad view of Lorentz and Poincare   invariance and spacetime symmetry, spacetime transformations for   non-inertial frames with limiting 4-dimensional symmetry and   field theory in non-inertial frames, and translation gauge   symmetry for gravity.</p>
    <p>Research in experimental physics at UMass Dartmouth includes   nuclear physics, condensed matter physics, traffic engineering,   and observational astronomy. The nuclear physics research   currently involves a series of measurements to investigate pion   photoproduction near threshold from the proton and (eventually)   the neutron. This project is a collaborative effort involving   researchers from the U.S. and Sweden, and will be undertaken   using the MAX-lab facility at Lund University in Lund, Sweden.   Research into the physical phenomena of liquid crystals and   polymers, a sub-discipline of condensed matter physics, currently   includes working toward the development of electronically   switchable diffraction gratings, which can steer and manage   impinging light. An area that uses both modeling and experimental   data is transportation engineering: specifically, transportation   modeling, queuing, optimization and car following theory. This   work involves the Florida Department of Transportation and the   Center for Advanced Transportation Systems Simulation, CATSS, in   Orlando, Florida. Observational astronomy research is focused on   stellar and galactic studies of binary stars. <i>Hubble</i> Space   Telescope data of extremely old binary stars are now being   analyzed, and a ground-based effort using speckle imaging at the   WIYN 3.5-m Telescope at Kitt Peak, Arizona is underway in   collaboration with Yale University to develop comprehensive   information of binaries in the solar neighborhood.</p>
    <p>For further information on these and other research activities,   please visit the department web page at <a href="http://www.umassd.edu/engineering/physics/">www.umassd.edu/engineering/physics/</a></p>
    <h3>Admission Requirements</h3>
    <p>Applicants must submit the required application materials to the   Graduate Office. The following aspects are related specifically   to the graduate physics program.</p>
    <p>Admission to the graduate physics program may be either for the   fall or the spring semester. Admission is competitive and   requires the completion of an undergraduate degree in physics or   a closely related field with a grade point average that attests   to the student&rsquo;s ability for graduate level study. The   General Record Examination (GRE) is not required for admission,   but the selection of candidates for financial support includes   consideration of GRE scores as well as Test of English as a   Foreign Language (TOEFL) scores for international students whose   native language is not English.</p>
    <h3>Financial Assistance</h3>
    <p>A limited number of teaching and research assistantships are   available. They are awarded on a competitive basis. The selection   of candidates is based on academic transcripts from the   student&rsquo;s home institution, three letters of recommendation   from professors or other senior scientists well acquainted with   the qualifications of the candidate, the GRE scores and, where   applicable, the TOEFL scores. Assistantships are awarded either   on a full-time or a partial basis. The number of applicants for   financial support has traditionally far exceeded the number of   assistantships available.</p>
    <p>Other assistance, such as loans or work study, may be available   to you. Please consult the chapter on &ldquo;Expenses and   Financial Assistance.&rdquo;</p>
    <h3>Contact</h3>
    <p>Dr Elliott Horch<br />
    Graduate Program Director, Physics<br />
    Assistant Professor of Physics<br />
    508 999-8360<br />
    <a href="mailto:ehorch@umassd.edu">ehorch@umassd.edu</a><br />
    <br />
    University of Massachusetts Dartmouth<br />
    285 Old Westport Road<br />
    North Dartmouth, MA 02747-2300</p>
    
  4. Switch back to WYSIWYG.
  5. Open the Replace dialog.
  6. Try to replace ")" with "*", do them one-by-one.
  7. A JavaScript error occurs in the middle of the replacement, but the replace operation itself seems undisrupted.

This bug was reported by dshafik form the IRC channel.

Change History (2)

comment:1 Changed 11 years ago by Davey Shafik

When doing a "Replace All" it DOES interrupt the Replace All - this is quite dangerous, as you might not realize with long documents.

comment:2 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy