Opened 11 years ago

Closed 11 years ago

#2315 closed Bug (duplicate)

FCKeditor.Net 2.5 gives wrong output

Reported by: Luca Leonardo Scorcia Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: FCKeditor 2.6.1
Keywords: Cc:

Description (last modified by Alfonso Martínez de Lizarrondo)

If the text typed in the editor contains html codes (like in a HTML tutorial) the content of ctlEditor.Value is messed up.

To reproduce, type into the editor the following lines:

How to format source code: <code>lol</code>

Submit and check the Value property. Expected result: "How to format source code:<br />&lt;code&gt;lol&lt;/code&gt;" Actual result: "How to format source code:<br /><code>lol</code>"

This bug makes impossible to display html codes.

The reason is an error in the FCKeditor.LoadPostData method; the lines

postedValue = postedValue.Replace("&amp;", "&");
postedValue = postedValue.Replace( "&lt;", "<" ) ;
postedValue = postedValue.Replace( "&gt;", ">" ) ;

should be instead:

postedValue = postedValue.Replace( "&lt;", "<" ) ;
postedValue = postedValue.Replace( "&gt;", ">" ) ;
postedValue = postedValue.Replace("&amp;", "&");

This way, the &amp;lt; will be correctly interpreted.

Change History (2)

comment:1 Changed 11 years ago by Luca Leonardo Scorcia

Oh well, the editor ate some line breaks. Hope you'll be able to understand what I wrote, in case let me know and I'll post a .txt file somewhere.

comment:2 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Description: modified (diff)
Resolution: duplicate
Status: newclosed

dup of #1908

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy