Opened 9 years ago

Closed 6 years ago

#2380 closed New Feature (invalid)

FCKEditor plugin for Wordpress developers' network

Reported by: lrussi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have recently spent a fair amount of time browsing for a WYSIWYG Editor plugin to implement on the ILSU Wps website. While, in fact, tinyMCE is not all bad, it does sometimes display awkward behavior when switching from the Visual to the HTML view. Plus, it keeps messing up <p>, <div> and <br/> tags.

I ultimately opted for Dean’s FCKEditor WordPress Plugin, since it features an up-to-date version of the FCKEditor sotware, featuring a user-friendly interface to perform ordinary maintenance tasks (such as uploading images or files in a specific folder on your server) and displaying the ability not to mess up those tags which tinyMCE gives problems with.

However, my fear is that, since this plugin rests for now on the shoulders of one man (Dean Lee, whom I personally thank for giving birth to the plugin in the first place), it might one day cease to be regularly updated to future versions of FCKEditor and WordPress. After all, this is what (so it seems) happened to the Xinha4WP plugin, a WordPress implementation of the Xinha open source editor, which “died” at version 1.2 beta.

In my view, the problem with one-man plugins is not so much that users do not improve them: quite on the contrary, I am fairly sure that, as with all Open Source software, there exist scattered groups of people working on the plugin code. However, the problem is that all such ”tweaks” (which may often consist of important bug fixes) rarely get by to a larger audience, meaning that plugin-hackers keep their findings and changes to themselves, and might not - actually - even regard themselves as developers. This, however, chills any incentive towards the creation of a truly integrated social network of developers. In fact, the countless but de-centralized efforts of many ultimately do not go into the generation of newer and better versions of the plugin. Moreover, original developers might get bored of constantly receving bug reports and help requests from less tech-savvy users, and might ultimately decide to give up the regular updating of the plugin altogether (after all - I believe - one thing is developing, another is implementing, which sometimes requires personalized care and might therefore be annoying to individually perform for free). Newbie users will further get discouraged by a plugin that contains long-known-but-never-fixed bugs, and ultimately look somewhere else, or just bend their head, and submit to tinyMCE.

Hence, I believe that, if we truly believe that FCKEditor deserves to stay in - and keep up with - WordPress (which - in my view - might become in the near future THE content management system, for its incredible ease of use, and hence the greatest source of FCKEditor users), the only way to keep this piece of software alive, and to have it survive the interests of its originator, is to set up a developers’ website, where users familiar with the relevant code may submit and, most importantly, share bug fixes to the FCKEditor plugin, to be ultimately integrated in newer versions. It is only by joining the decentralized efforts of many toward a single goal that it might be possible to achieve it, otherwise, they’ll just disperse.

Change History (2)

comment:1 Changed 9 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy