Opened 9 years ago

Closed 9 years ago

#2390 closed Bug (fixed)

[IE7] Indentation doesn't work on <p> tag the first time it's clicked, but works the second time.

Reported by: Adam Miskiewicz Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.3
Component: General Version: FCKeditor 2.6.2
Keywords: Confirmed IE Review+ Cc:

Description

This bug happens both on my personal site as well as the demo FCKEditor at http://www.fckeditor.net/demo, so I know it's a editor-wide issue. Also, it only happens on IE7.

When you type any amount of text (longer than one line, and consisting of more than one paragraph tag), try to indent any part of the text, and then either view the source or submit the form that FCKEditor is part of, it removes the indenting that you performed. If you do the same thing as above, but do not submit the form, and simply remove the indentation and re-indent the text, it performs as expected.

Example and How to Reproduce:

Type the following text into an empty FCKEditor window in Internet Explorer 7 (a good editor to test on is the demo editor, because it is a default installation):

Test Line 1 [PRESS ENTER]
Test Line 2 [PRESS ENTER]
Test Line 3 [PRESS ENTER]
Test Line 4 [PRESS ENTER]

Now indent lines 2 and 3. View the source. Notice that there is no "style='margin-left:40px'" as an attribute of any of the <p> tags.

Attachments (2)

2390.patch (1.5 KB) - added by Martin Kou 9 years ago.
2390_2.patch (2.3 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by Martin Kou

Keywords: Confirmed IE added; indent indentation p margin removed
Owner: set to Martin Kou
Status: newassigned

Changed 9 years ago by Martin Kou

Attachment: 2390.patch added

comment:2 Changed 9 years ago by Martin Kou

Keywords: Review? added

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Martin Kou to Frederico Caldeira Knabben
Status: assignednew

This issue is not limited to <p> elements. It happens with any kind of element (just try EnterMode='div').

I've worked on a new patch for it.

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 2390_2.patch added

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:5 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [2280].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy