Opened 11 years ago

Closed 8 years ago

#2490 closed Bug (invalid)

Create list delete or split parent element

Reported by: Abenzka Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.5.1
Keywords: Cc:

Description

If my cursor is into a div element (or p) and i click numbered list to insert a list, the div element will be delete, or splitted if there is some text before and after my cursor.

This not happen with table elements.

Attachments (1)

fckList.jpg (109.2 KB) - added by Abenzka 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralCore : Lists
Keywords: Pending WorksForMe added

I don't notice any problem. Can you provide detailed steps to reproduce the problem? You have marked this bug as SVN, does it means that it did work properly in 2.6.3?

Changed 11 years ago by Abenzka

Attachment: fckList.jpg added

comment:2 Changed 11 years ago by Abenzka

This bug is also present in demo and v2.5.1. I cannot test other version.

Create a div element into editor area with "Create Div Container" toolbar button, it create a p element into div. Now the cursor is into the p element. If I click "Numbered List" button the p element will be deleted. If I click "Numbered List" while my cursor is into a div element this will be deleted or splitted.

comment:3 Changed 11 years ago by Abenzka

Some update?

comment:4 Changed 11 years ago by Artur Formella

Keywords: Confirmed added; Pending WorksForMe removed

Confirmed in FF3 and IE7. Steps to reproduce:

Insert in source:

<div>aaaaaaaaaa
<div>
   11111111111111
</div>
bbbbbbb</div>

-Click 11111111111111

-Click numbered list

-Back to source

<div>aaaaaaaaaa
<ol>
    <li>11111111111111</li>
</ol>
bbbbbbb</div>

comment:5 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Version: SVNFCKeditor 2.5.1

comment:6 Changed 8 years ago by Krzysztof Studnik

Resolution: invalid
Status: confirmedclosed

IMO not a bug. Inner <p> or <div> is converted into list item.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy