Opened 11 years ago

Closed 8 years ago

#2491 closed Bug (worksforme)

undo, redo, undo enters duplicate entry in history in IE7 and FF3

Reported by: Paul Moers Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: FCKeditor 2.5 Beta
Keywords: Cc:

Description

To replicate: insert an image, in the URL input enter a relative URL or browse server and click ok > click undo, then redo and again undo > a duplicate entry of the image insertion seems added to the history manager.

this doesn't seemt o happen with an absolute URL, e.g. http://www.fckeditor.net/forums/styles/fckeditor/theme/images/logotop.gif, but it does happen with '/forums/styles/fckeditor/theme/images/logotop.gif'

Tested only in IE7 and firefox 3 on windows XP. Tested in FCKeditor 2.6.3 at http://www.fckeditor.net/demo and nightly 2.5 SVN Build 20005 at http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

Change History (3)

comment:1 Changed 11 years ago by Paul Moers

Maybe this happens because the selection is unselected in the editor... because when I run Selection.Collapse(); just after undo or redo, firefox seems to be adding entries too.

comment:2 Changed 11 years ago by Artur Formella

Component: GeneralCore : Undo/Redo
Keywords: Confirmed added
Summary: undo, redo, undo enters duplicate entry in history in IEundo, redo, undo enters duplicate entry in history in IE7 and FF3
Version: FCKeditor 2.5 Beta

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy