Opened 11 years ago

Closed 8 years ago

#2551 closed Bug (worksforme)

Text and background color popups incorrectly positioned

Reported by: highjinx Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6 Beta
Keywords: Cc:

Description

The text and background color popups are incorrectly positioned vertically (they show up above the editor window) when scrolled. I have reproduced this in FF 3 and Chrome/Safari on Windows. IE works correctly.

This was introduced in [1091]. The problem is in editor/_source/internals/fcktools.js, FCKTools.GetDocumentPosition(). If I comment out the "if ( ! FCKBrowserInfo.IsOpera )" line around line 527, everything works fine.

Attached is a test case.

Attachments (1)

test1.html (2.2 KB) - added by highjinx 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by highjinx

Attachment: test1.html added

comment:1 Changed 11 years ago by Artur Formella

Version: FCKeditor 2.6 Beta

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy