Opened 9 years ago

Closed 9 years ago

#2695 closed Task (invalid)

Don't convert newline characters into <BR /> inside <PRE>...</PRE>

Reported by: Emerson José Silveira da Costa Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending WorksForMe Cc:

Description

I use FCKeditor at Seedwiki. When I type, say, a computer program inside <PRE>...</PRE> tags, all newline characters become <BR /> tags. A code like:

<pre>
FOR A = 0 TO 255
   PRINT CHR$(A);
NEXT A
</pre>

becomes a LONG SINGLE line:

<pre>FOR A = 0 TO 255<br />   PRINT CHR$(A);<br />NEXT A</pre>

(Just imagine a 100+ line program...)

For a number of reasons sometimes it's preferable to use the TextArea editor, or simply we are stuch with a browser where FCKeditor's WYSIWYG feature doesn't work. In those cases, we must face the nightmare of editing that long single line.

Hence my suggestion: don't convert newline characters into <BR /> inside <PRE>...</PRE> tags.

Change History (4)

comment:1 Changed 9 years ago by Michael Osipov

You should consider using CodePress instead of FCKeditor.

comment:2 Changed 9 years ago by Emerson José Silveira da Costa

Using CodePress is not an option. Seedwiki just happens to use FCKeditor.

comment:3 Changed 9 years ago by Artur Formella

Keywords: Pending WorksForMe added

I was unable to reproduce this bug. Could you provide more information?

comment:4 Changed 9 years ago by Emerson José Silveira da Costa

Resolution: invalid
Status: newclosed

Indeed, I have tried the Nightly Build and it is working fine. No <BR /> is introduced.

The problem occurs at SeedWiki.com wikis. I guess they're using an outdated version of FCKeditor.

Thanks a lot, anyway.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy