Opened 8 years ago

Closed 5 years ago

#2987 closed Bug (fixed)

All fake elements get lost after drag-and-drop in Webkit

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0 Beta 2
Keywords: Safari CantFix Cc:

Description

Procedures

  1. Open the replace by code example page in Safari;
  2. Select the beginning of the text line;
  3. Click Anchor button to open dialog, input 'anchor' in 'Anchor Name' field, close it with ok;
  4. Select the inserted fake element(anchor), perform drag-and-drop to the end of line.
  • Actual Result : The fake element disappeared right at the drop region.

Change History (11)

comment:1 Changed 8 years ago by Garry Yao

A reduced reason is found that the fake element after drop(cloned) has lost all attributes including class.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

Regression? See #566.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

comment:4 Changed 8 years ago by Artur Formella

Safari drops attributes of <img> and <input type="image"> It seems to be a Webkit bug. TinyMCE as the same problem.

ondragstart=function(){return false} works only partially.

comment:5 Changed 8 years ago by Alfonso Martínez de Lizarrondo

This is working fine in MacOS, but fails on windows, so the webkit bug is https://bugs.webkit.org/show_bug.cgi?id=16067

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: CantFix added

Yup... this looks like one of those "sit and wait" bugs for us. Hopefully WebKit gonna get fixed soon.

I'm leaving it opened for now, but "CantFix".

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Priority: HighNormal

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0

comment:9 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Version: SVN (FCKeditor)CKEditor 3.0 Beta 2

comment:10 Changed 5 years ago by Jakub Ś

Seems that ticket is almost fixed - you can move around the anchor in Safari and Chrome. The only problem is that when you switch to source you will see that Chrome 20 adds background color:

<a name="anchor" style="background-color: rgb(255, 255, 255); ">This</a>

and Safari a lot more

<a name="ffff" style="background-image: url(http://localhost/ckeditor/_source/plugins/link/images/anchor.gif); background-attachment: initial; background-origin: initial; background-clip: initial; background-color: initial; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px; border-left-width: 1px; border-top-style: dotted; border-right-style: dotted; border-bottom-style: dotted; border-left-style: dotted; border-top-color: rgb(0, 0, 255); border-right-color: rgb(0, 0, 255); border-bottom-color: rgb(0, 0, 255); border-left-color: rgb(0, 0, 255); padding-left: 18px; cursor: auto; background-position: 0% 50%; background-repeat: no-repeat no-repeat; ">This</a>
Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:11 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I have just checked this problem in latest trunk in Safari 5.1.7 and Chrome 22 and this problem seems to be fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy