Opened 11 years ago

Closed 11 years ago

#3008 closed Bug (fixed)

plugin:form fields certain attributes not commited in IE

Reported by: Garry Yao Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: IE Confirmed Review+ Cc:

Description (last modified by Garry Yao)

Specifically, attributes name,style and check box based options didn't get committed.

Functional Testcase

Provide a test case for checkbox, others field types could also be reproduced in same way.

Attachments (4)

test-checkbox-all.patch (3.1 KB) - added by Garry Yao 11 years ago.
Functional Testcase
test_element_setAttribute.patch (1.4 KB) - added by Garry Yao 11 years ago.
Unit Test Case
3008.patch (8.0 KB) - added by Garry Yao 11 years ago.
3008_2.patch (33.7 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (17)

Changed 11 years ago by Garry Yao

Attachment: test-checkbox-all.patch added

Functional Testcase

comment:1 Changed 11 years ago by Garry Yao

Description: modified (diff)
Summary: plugin:checkbox assign certain attributes not working in IEplugin:checkbox/radio assign certain attributes not working in IE

comment:2 Changed 11 years ago by Garry Yao

Summary: plugin:checkbox/radio assign certain attributes not working in IEplugin:form all field type certain attributes not working in IE

comment:3 Changed 11 years ago by Garry Yao

Description: modified (diff)
Summary: plugin:form all field type certain attributes not working in IEplugin:form fields certain attributes not commited in IE

comment:4 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

It is very strange.

var element2 = CKEDITOR.dom.element.createFromHtml( '<input name="bbbbbbb"></input>' );
element2.$.setAttribute( 'name', 'ccccccc' );
element2.$.name= 'ddddddd';
element2.setAttribute( 'name', 'aaaaaaa' );

alert(element2.getNameAtt() ); 		// IE returns aaaaaaa
alert(element2.$.name ); 		// IE returns aaaaaaa
alert(element2.$.getAttribute('name') ); // IE returns aaaaaaa
alert(element2.getAttribute('name') ); 	// IE returns bbbbbbb
alert(element2.getOuterHtml());		// IE returns <INPUT name="bbbbbbb" _cke_expando=237></INPUT>
	

var element3 = CKEDITOR.dom.element.createFromHtml( '<input test="bbbbbbb"></input>' );
element3.setAttribute( 'test', 'aaaaaaa' );

alert(element3.getAttribute('test') ); 	// returns aaaaaaa
alert(element3.getOuterHtml());		// returns <INPUT test="aaaaaaa" _cke_expando=239></INPUT>
	

In FF, webkit and opera works fine

Changed 11 years ago by Garry Yao

Unit Test Case

comment:5 in reply to:  4 Changed 11 years ago by Garry Yao

Replying to arczi: As indicate by Artur, this's been a browser bug from IE, I'm attaching the TC for it, but I guess we can't relay on IE for it, probably it could be fixed by utilize expando property .

Changed 11 years ago by Garry Yao

Attachment: 3008.patch added

comment:6 Changed 11 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:7 Changed 11 years ago by Martin Kou

Keywords: Review- added; Review? removed
Owner: changed from Garry Yao to Martin Kou
Status: assignednew

Review- because:

  1. The patch didn't fix the checkbox bug.
  2. The patch is causing JavaScript error in selection field dialog.

I'm taking over the ticket.

Changed 11 years ago by Martin Kou

Attachment: 3008_2.patch added

comment:8 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

Quite a lot of problems were found with the forms plugin with the previous patch, and were fixed in the new proposed patch:

  1. Checkboxes in radio and checkbox dialogs don't work.
  2. JavaScript error in selection field dialog.
  3. Attribute values are not removed when they're cleared by the user in dialog.
  4. Setting the "value" attribute in all form element dialogs do not work.
  5. Changing the "type" attribute in all applicable form element dialogs in IE causes JavaScript errors.
  6. When editing text areas in IE with out cols and rows attributes specified, the text field dialog would still display "20" and "4" as the attribute values.
  7. Similarly, the size and maxlength attributes are being displayed as "20" and "2147483647"in the text field dialog in IE even though the attributes don't exist in HTML.
  8. The logic of the "Value" text field in selection dialog isn't complete (it's still left as a TODO).
  9. The form dialog does not edit forms in IE because of wrong selected element detection logic.

comment:9 Changed 11 years ago by Martin Kou

#3070 is marked as a dup to this ticket because the proposed patch fixes it as well.

comment:10 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:11 Changed 11 years ago by Garry Yao

Keywords: Review- added; Review+ removed

As discussed with Martin, a new method of 'hasAttribute' will be introduced to eliminate the default value checking under IE.

comment:12 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review- removed

#3403 is opening for this problem.

comment:13 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [3407].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy