Opened 11 years ago

Closed 11 years ago

#3042 closed Bug (fixed)

Accessibility not complete on toolbar items

Reported by: Garry Yao Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: Accessibility Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

Certain toolbar items are not correctly with title and tabIndex.

Attachments (5)

test-toolbar.patch (3.8 KB) - added by Garry Yao 11 years ago.
Functional Test Case
3042.patch (7.2 KB) - added by Garry Yao 11 years ago.
3042_2.patch (7.6 KB) - added by Garry Yao 11 years ago.
3042_3.patch (15.9 KB) - added by Frederico Caldeira Knabben 11 years ago.
3042_4.patch (15.9 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

In test case itemElement.getAttribute( 'title' ) is a string or a null and it is impossible to get 'true'.

It should be changed to:

assert.isTrue( !!itemElement.getAttribute( 'title' ),
'Toolbar item ' + col + ' doesn\'t have description title.');

Changed 11 years ago by Garry Yao

Attachment: test-toolbar.patch added

Functional Test Case

comment:2 Changed 11 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 11 years ago by Garry Yao

Keywords: Review? removed

This one is going to be fixed along with #3073.

comment:4 in reply to:  3 ; Changed 11 years ago by Frederico Caldeira Knabben

Replying to garry.yao:

This one is going to be fixed along with #3073.

No it's not. #3073 is supposed to handle the TAB move over the toolbar only. We still need to make the combos contents accessible:

  1. TAB to combo and hit ENTER to open it (#3073). The combo panel opens with no options selected.
  2. Use ( ARROW-DOWN | TAB ) && ( ARROW-UP | SHIFT-TAB) to move through the panel items. (It should simply stop when hitting the first/last item).
  3. ENTER key to execute the item (should be ready already).
  4. or ESC to close the panel and return the focus back to the combo.

Points 2, 3 and 4 are not handled by #3073.

Changed 11 years ago by Garry Yao

Attachment: 3042.patch added

comment:5 in reply to:  4 Changed 11 years ago by Garry Yao

Keywords: Review? added

Replying to fredck:

Points 2, 3 and 4 are not handled by #3073.

The patch take care of the missing features.

Changed 11 years ago by Garry Yao

Attachment: 3042_2.patch added

comment:6 Changed 11 years ago by Garry Yao

IE's not expecting keydown on Window, so register this event on Document instead.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

Your patch is quite interesting. I was tending to accept it, but it came to my eyes that it would be much better if the key handling logic would be contained by the block itself, instead of the richcombo. In this way, we could reuse it for other blocks, like the color selectors or the context menu.

There were also other things missing in this patch, like the keys support in the color selectors. There were also some fixes to the coding style, as well as simplifications that could be done.

Due to the extreme urgency we have for this ticket, I'll be coming with a new patch for it.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3042_3.patch added

comment:8 Changed 11 years ago by Frederico Caldeira Knabben

Component: GeneralAccessibility
Keywords: Review? added; Review- removed
Status: newassigned

This new patch is supposed to fix "all" issues regarding the toolbar combos and color selectors accessibility.

comment:9 Changed 11 years ago by Garry Yao

Keywords: Review- added; Review? removed

The patch has the following problems:

  1. BOM is attaching to plugin.js file in both 'richCombo' and 'listBlock';
  2. The logic at Line 265 of _source/plugins/panel/plugin.js is counting invisible list item, which cause the first two 'arrowDown' key within Styles Combo been absorbed, it's better to bypass those items;
  3. The 'focusIndex' is not correct in colorbutton panel, which always start at the position of last focused box , no matter if the box is selected.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3042_4.patch added

comment:10 in reply to:  9 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

Replying to garry.yao:

  1. BOM is attaching to plugin.js file in both 'richCombo' and 'listBlock';

Many of of files have the BOM. This thing doesn't need to be checked as it is supposed to be made uniform during the release process.

In any case, I believe the new patch doesn't have it.

  1. The logic at Line 265 of _source/plugins/panel/plugin.js is counting invisible list item, which cause the first two 'arrowDown' key within Styles Combo been absorbed, it's better to bypass those items;

It looks like we can't rely on styles for this check. I've changed it.

  1. The 'focusIndex' is not correct in colorbutton panel, which always start at the position of last focused box , no matter if the box is selected.

The panel now resets it before showing the block.

comment:11 Changed 11 years ago by Garry Yao

Keywords: Review- added; Review? removed

In Webkit, Esc not working with Text Color panel, when pressed, the focus is not returned to button link, works for Bg Color though.

comment:12 in reply to:  11 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

Replying to garry.yao:

In Webkit, Esc not working with Text Color panel, when pressed, the focus is not returned to button link, works for Bg Color though.

This is not critical. We can have a ticket for it as soon as this one gets committed.

comment:13 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:14 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3226].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy