Opened 10 years ago

Closed 10 years ago

#3094 closed Bug (duplicate)

Block style problem with paragraphs

Reported by: Garry Yao Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: Core : Styles Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

Procedures

  1. Open the replace by code example page;
  2. Initial the document with the following content and selection:
    ^	text
    	<p>paragraph1</p>
    	<p>paragraph2</p>
    ^
    
  3. Click on stylesCombo to open drop-down, select Blue Title option.
  • Actual Result: The middle paragraph was left untouched.
    <h3 style="color: Blue;">
    	text</h3>
    <p>
    	paragraph1</p>
    <h3 style="color: Blue;">
    	paragraph2</h3>
    

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Priority: NormalHigh

Note that the only way to reproduce it now is by manually modifying the editor contents with a tool like Firebug, because the orphan paragraph gets fixed when switching back from source.

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Martin Kou

This error is caused by exactly the same line of code in domiterator mentioned in #3093.

comment:4 Changed 10 years ago by Martin Kou

Resolution: duplicate
Status: assignedclosed

I've proposed another patch in #3093 that fixes this issue as well. So marking this as a dup of #3093.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy