Opened 10 years ago

Closed 10 years ago

#3093 closed Bug (fixed)

Block style problem with list item

Reported by: Garry Yao Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description (last modified by Garry Yao)

This happened to all block style function.

Procedures

  1. Open the replace by code example page;
  2. Initial the document with the following content and selection:
    ^	<p>text</p>
    	<ol>
    		<li>level1
    			<ul>
    				<li>level2</li>
    			</ul>
    		</li>
    	</ol>
    ^
    
  3. Click on stylesCombo to open drop-down, select Blue Title option.
  • Actual Result: The second level list item is not formatted.
    <h3 style="color: Blue;">
    	text</h3>
    <ol>
    	<li>
    		<h3 style="color: Blue;">
    			level1</h3>
    		<ul>
    			<li>
    				level2</li>
    		</ul>
    	</li>
    </ol>
    
    

Attachments (2)

3093.patch (971 bytes) - added by Martin Kou 10 years ago.
3093_2.patch (560 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Garry Yao

Description: modified (diff)
Summary: plugin:stylesCombo problem with list itemBlock style problem with list item

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

comment:3 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 3093.patch added

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review? added

The bug is found to be caused by the changes to line 138, 139 of the fckdomiterator.js class back in FCKeditor 2.6.x - which is subsequently ported to CKEditor 3. The relevant changesets are [1511], [2274], [2777].

I don't really understand what's happening with that 2 lines but quite a lot of bugs were caused by them in the past. Skipping them for ul and ol nodes seem to fix the issue without causing regression bugs with #1717, #2387 and #2679. But this area of the code definitely needs to be reviewed.

Changed 10 years ago by Martin Kou

Attachment: 3093_2.patch added

comment:5 Changed 10 years ago by Martin Kou

Proposing another patch that's simpler and works for all known test cases.

It fixes #3094 as well.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3293].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy