Opened 9 years ago

Closed 9 years ago

#3095 closed Bug (fixed)

Indent/Outdent problem with list item

Reported by: Garry Yao Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

Procedures

  1. Open the replace by code example page;
  2. Initial the document with the following content and selection:
    	<ol>
    		<li>level1</li>
    		<li>leve1
    			<ol>
    				<li>^level2</li>
    			</ol>
    		</li>
    	</ol>
    
    
  3. Click on Outdent button to degrade list item once.
  4. Click on Indent button to arise list item once.
  • Actual Result: The previous list item was indented too.
    <ol>
    	<li>
    		level1
    		<ol>
    			<li>
    				leve1</li>
    			<li>
    				level2</li>
    		</ol>
    	</li>
    </ol>
    

Attachments (1)

3095.patch (1.5 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Martin Kou

Keywords: Confirmed added
Owner: set to Martin Kou
Status: newassigned

comment:2 Changed 9 years ago by Martin Kou

Priority: NormalHigh

Changed 9 years ago by Martin Kou

Attachment: 3095.patch added

comment:3 Changed 9 years ago by Martin Kou

Keywords: Review? added

Turns out the bug was caused by a small logic error in the indent plugin, which is feeding arrayToList() the wrong UL or OL node to begin with.

There's also a small bugfix for the list plugin in the patch.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3253].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy