Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#310 closed Bug (duplicate)

Most files of Version 2.4.1 are corrupted

Reported by: Matthias Gallas Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.1
Keywords: Cc:

Description

Most files of 2.4.1 are corrupted, wich means that at the beginning of a lot of files are stored additional signs wich causes issues and missfunctions when you try to use version 2.4.1. The problem ist that this additional signs in the most files only can be seen with a HEX Editor. Affected are a lot of .js, .html and .php files in the whole package.

The hex code wich should be deleted at the beginning of the affected files is:

ef bb bf

The related ASCII signs are:



Attention: In some files this code is stored mor then on time at the beginning of the files.

Additional Informations are also here: http://sourceforge.net/forum/forum.php?thread_id=1700889&forum_id=257179

A ticket wich i could solve with manually cleaning all files is here: http://dev.fckeditor.net/ticket/308

By the way, after manually changing all the affected files 2.4.1 is great.

Keep on that good work

Matthias

Change History (8)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.4.2
Priority: HighNormal
Resolution: duplicate
Status: newclosed

DUP of #279

comment:2 in reply to:  1 Changed 12 years ago by Matthias Gallas

Sorry to say, but the solution from #279 only means to store 3 files again. But there are a lot of more files in the package affected from this issue. If you mean the problem is solved laeve this ticket closed. I made an SVN export right now and the files are not fixed there and also they are not fixed in the download package.

Matthias

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Check out the nightly build.

comment:4 Changed 12 years ago by Matthias Gallas

I checked the nightly build right now and there is nothing fixed. f.e. view the fckonfig.js with an Hex Editor and you will see what i mean. And this is in a lot of files.

Matthias

comment:5 Changed 12 years ago by Matthias Gallas

Klick here for an example picture: http://www.familie-gallas.de/media/Image/fckeditor.jpg

Matthias

comment:6 Changed 12 years ago by Frederico Caldeira Knabben

.js and .asp files "must" have the UTF-8 BOM. All other files will not have it. Version 2.4.1 has been shipped with the right opposite of it.

comment:7 Changed 12 years ago by Matthias Gallas

That's correct, but PHP has a bug with the BOM wich causes this wrong displays and issues. So as far as i know the BOM is not absolutely necessary for UTF8. It also works without BOM. Found this here in a 2 minute googling:

http://bugs.php.net/bug.php?id=22108

So for UTF8 it makes no difference if BOM is there or not, but PHP didn't work in some cases if files are stored with BOM maybe its better to store all files without BOM.

Matthias

comment:8 Changed 12 years ago by Matthias Gallas

Ok after doing some more tests I'm according fredck that it is correct to store all .js and .asp files in UTF-8 with BOM. This works also on php enviroments. All other files (especially .php and .html) should be cleaned from the boom, but this seems already to be fixed in the fckreleaser and the latest nighly build. So nothing else has to be done and this ticket can be leaved as closed.

Thanks for this great editor.

Matthias

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy