Opened 9 years ago

Closed 4 years ago

#3183 closed Bug (fixed)

IE8: Domain relaxation for panels fails

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4
Keywords: IE8 Cc:

Description

As reported in http://www.fckeditor.net/forums/viewtopic.php?f=6&t=13378

the line 54 in fckpanel.js gives a permission error (Access denied), if the editor is placed in a page using domain relaxation.

This is the first part that fails:

		this.Document = this._Popup.document ;

Change History (4)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.5

maybe too late now, but at least it deserves to be looked at.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

I've tried playing with this with no success. It looks like a new (bug) restriction introduced with IE8. From MSDN:

Note: Pages that change the document.domain property before creating the popup object may receive an "Access is denied" error message when accessing the pop-up object. Changes made to document.domain in the calling page will not propagate to the new pop-up object; currently, this is a design restriction that serves to limit access with the pop-up object.

We still have today to work on this, but I'm really afraid we'll miss this fix for the release.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6.5

Still no luck with this one. For now, CKEditor is the solution for it.

comment:4 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

FCKeditor is no longer supported and I wasn't able to reproduce this problem on latest CKEditor 4.3.x and IE8.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy