Opened 10 years ago

Closed 10 years ago

#3415 closed Bug (fixed)

Cannot tab back into text area on all Paste dialogs

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: Accessibility Version:
Keywords: IBM Confirmed Review+ Cc:

Description

When a paste dialog is opened, e.g. Paste from Word, the cursor will initially be focused inside the text area. After tabbing out of the text area, it is not possible to tab back into it.

Attachments (1)

3415.patch (8.8 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

We're having this bug because there's no logic for handling tab focus for raw html elements in dialog definitions yet - which is used to define the editable areas in paste dialogs.

I've written a patch to add logical support for that in #3291. #3291's patch also fixes the tab order in Paste from Word dialog. Focus order in Paste and Paste as Plaintext dialogs remains to be fixed in this ticket.

Changed 10 years ago by Martin Kou

Attachment: 3415.patch added

comment:3 Changed 10 years ago by Martin Kou

Keywords: Review? added

The patch fixes two critical errors in addition to adding tab focus support in the paste dialogs:

  1. Fixed permission denied error at Paste dialog opening in IE.
  2. Fixed JavaScript error when OK is pressed in Paste From Word dialog.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3485].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy