Opened 10 years ago

Closed 10 years ago

#3514 closed Bug (fixed)

[IE] dom.getFrameDocument still causes random errors

Reported by: Tobiasz Cudnik Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: IE Confirmed Review+ Cc:

Description

Function dom.getFrameDocument still causes random errors in IE when accessing $.contentWindow.document.

Although there is alredy some workaround for that, sometimes it still causing errors, like this one below (IE8 strict, polish language of dump, but ive translated keywords):

Szczegóły błędu na stronie sieci Web

Agent użytkownika: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)
Sygnatura czasowa: Wed, 13 May 2009 11:51:13 UTC


Wiadomość: Permission denied

Line: 1251
Char: 4
Kod: 0
Identyfikator URI: http://10.0.2.2/ckeditor/_source/core/dom/element.js


Wiadomość: Permission denied
Line: 1212
Char: 7
Kod: 0
Identyfikator URI: http://10.0.2.2/ckeditor/_source/plugins/dialogui/plugin.js

It have happened using link dialog. In effect i was unable to close dialog using "OK" button.

Another example is #3491.

I think it can be easier to reproduce this on slower machines.

Attachments (1)

3514.patch (540 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Garry Yao

I guess we need a unit test case for this with appropriate pre-condition.

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

It's not random for me, I get the permission denied error every time I open link, image or flash dialog.

It seems to have to do with the file input iframe.

Changed 10 years ago by Martin Kou

Attachment: 3514.patch added

comment:3 Changed 10 years ago by Martin Kou

Keywords: Review? added
Version: SVN (CKEditor)

This is a regression bug caused by [3481]. The setTimeout logic is not needed in IE and causes errors. So let's just take it out.

If more problems with the file input dialogs pop up, then we may have to change to another approach for fixing #3465.

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3525].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy