Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#358 closed Bug (duplicate)

CDATA processing adds extra CRLF in IE

Reported by: simone Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description (last modified by simone)

I found a strange problem with the handing of CDATA sections inside the Source View. It affects only IE:

step to reproduce the bug:

  1. Go to the test page (http://www.fckeditor.net/nightly/fckeditor/_samples/default.html)
  1. Go to source view and delete everything
  1. Paste into the source view the following text

<style type="text/css"><![CDATA[ .blah {

font-size: small;

} ]]></style>

  1. Go to the normal view and than back to the source view
  1. You get the following text:

<p><style type="text/css"> <![CDATA[ .blah {

font-size: small;

} ]]></style></p>

  1. If you reiterate the same switching between the views, FCKeditor adds a new line everytime.

That doesn't happen in Firefox

Change History (6)

comment:1 Changed 12 years ago by simone

Description: modified (diff)

comment:2 Changed 12 years ago by simone

Milestone: FCKeditor 2.4.3

comment:3 Changed 12 years ago by simone

Summary: CDATA processing adds extra CRLFCDATA processing adds extra CRLF in IE

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: newclosed

Actually it has nothing to do with CDATA, but with <style>.

This is a DUP of #403.

comment:5 Changed 12 years ago by simone

usually bugs with higher number are marked as duplicate and removed, not the opposite :)

comment:6 in reply to:  5 Changed 12 years ago by Frederico Caldeira Knabben

Replying to simonech:

usually bugs with higher number are marked as duplicate and removed, not the opposite :)

I know... it is just happening because not all bugs have been moved from SF yet.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy