Opened 11 years ago

Closed 10 years ago

#3633 closed Bug (fixed)

Default context menu isn't disabled in toolbar, status bar, panels...

Reported by: Alfonso Martínez de Lizarrondo Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

Load CKEditor and right click in the toolbar, status bar, any floating panel or context menu...

The default browser context menu is shown instead of showing nothing.

Attachments (4)

3633.patch (2.1 KB) - added by Tobiasz Cudnik 10 years ago.
3633_2.patch (2.0 KB) - added by Tobiasz Cudnik 10 years ago.
3633_3.patch (724 bytes) - added by Garry Yao 10 years ago.
3633_4.patch (2.5 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Milestone: CKEditor 3.1

comment:2 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3633.patch added

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed

Maybe it's better to add one single event preventer on the editor chrome instead?

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3633_2.patch added

comment:5 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

I've merged preventers for toolbar and bottom part of chrome, but floatpanels have to have them separately.

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Tobiasz Cudnik

Fixed with [4178].

comment:8 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

comment:9 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review- added; Review+ removed
Resolution: fixed
Status: closedreopened

[4178] (3633_2.patch) disables context menu in source area, which is an regression.

comment:10 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

I'm proposing including first patch 3633.patch because of reason mentioned above.

Changed 10 years ago by Garry Yao

Attachment: 3633_3.patch added

comment:11 Changed 10 years ago by Garry Yao

Nice catch, but the advantages of prevent at the chrome level is that we can make sure every corner of the chrome is covered.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3633_4.patch added

comment:12 Changed 10 years ago by Tobiasz Cudnik

I'm proposing a bit more flexible solution, although your's Garry one should work fine too.

Which one is more suitable for us ?

comment:13 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

R+ for 3633_4.patch

comment:14 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: reopenedclosed

Post fixed with [4182] and [4183].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy