Opened 10 years ago

Closed 10 years ago

#3651 closed Bug (invalid)

Setting height of editor is broken in IE8 Standards Mode

Reported by: Michael Owned by:
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version:
Keywords: Cc:

Description

Environment: MS Vista (also XP vm), Internet Explorer 8 Standards Mode

Issue: Setting the height of the editor from JavaScript does not work in Internet Explorer 8 Standards Mode. Standards mode computes 100% height a little differently to other other browsers, and therefore doesn't make full use of the available space.

Sample:

<html>
<head>
<script type="text/javascript" src="/html/includes/fckeditor/fckeditor.js"></script>
<script type="text/javascript">
   function init(){
      var fckEditorObj = new FCKeditor('details');
      fckEditorObj.BasePath = "/html/includes/fckeditor/";
      fckEditorObj.Height = "600px";
      fckEditorObj.ReplaceTextarea();
   }
</script>
<style type="text/css">
   div.fckHolder {
      height:600px;
      width:800px;
      background-color:gray; 
      border:2px solid red;
   }
</style>
</head>
<body onload="init()">
   <div class="fckHolder">
      <textarea id="details"></textarea>
   </div>
</body>
</html>

The above code should set the editor height to 600px, however you'll notice that the iframe ("detailsFrame" in this case) sets itself to 600px (you cant see the gray background of the div) while the editable text area stays on the default 200px.

The fix i would think is the body within the "detailsFrame" iframe needs to be given a specified height other than the 100%.

Please advise of the solution

Thanks in advance,

Michael

Attachments (2)

fckIE8HeightTest.html (786 bytes) - added by Michael 10 years ago.
Example of code seen earlier.
3651.jpg (96.5 KB) - added by Artur Formella 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Michael

Attachment: fckIE8HeightTest.html added

Example of code seen earlier.

Changed 10 years ago by Artur Formella

Attachment: 3651.jpg added

comment:1 Changed 10 years ago by Artur Formella

Keywords: WorksForMe Pending added

Could you provide more information to reproduce this bug? Please also see the attachment.

comment:2 Changed 10 years ago by Michael

Can you ensure that your in standards mode.

  1. Open IE8
  2. Tools > Developer Tools
  3. From top menu in Developer Tools set the following:
    • Browser Mode: Internet Explorer 8 (_NOT Compatibility Mode_)
    • Document Mode: Internet Explorer 8 Standards Mode

comment:3 Changed 10 years ago by Michael

Were you able to reproduce this in Standards Mode. Please advise the status of this issue. Thank you.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6.5

We'll be working on IE8 issues for the 2.6.5, so we'll check this issue for that.

comment:5 Changed 10 years ago by Martin Kou

Keywords: Confirmed IE8 added; WorksForMe Pending removed

Confirmed the bug in IE8

comment:6 Changed 10 years ago by Martin Kou

Keywords: Confirmed IE8 removed
Resolution: invalid
Status: newclosed

Wait.. the issue actually doesn't happen for normal users, here's why:

In a page with FCKeditor, there're at least 2 iframes.

  1. The iframe containing the editor UI
  2. Inside the iframe from point 1, the editing area itself.

What you're concerning is the 100% height inside the editor UI iframe. But the contents of that iframe is supposedly always rendered in quirks mode because the contents in that iframe is completely controlled by FCKeditor.

Forcing IE8 to standards mode via the developer toolbar forces IE8 to render even FCKeditor's iframes in standards mode. But that's not possible for non-developer usage. The closest case you can get is just writing the containing HTML page to be rendered in standards mode (e.g. by adding the <!doctype html> tag) - but that's perfectly supported at the moment.

So this isn't really a bug, because we can't be expected to support the kinds of dynamic changes that you can do only with the developer tool.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy