Opened 10 years ago

Closed 6 years ago

#3786 closed Bug (fixed)

Copying / pasting in IE creates font tags

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc: pomu@…

Description (last modified by Wiktor Walc)

Steps to reproduce:

  1. Create two paragraphs
    This is some sample text.
    
    This is some sample text.
    
  1. If you make the first line green, select some text and paste it in the second line, you'll get:
<p>
	This is <font color="#008000">some </font>some sample text.</p>

Change History (9)

comment:1 Changed 10 years ago by Wiktor Walc

Description: modified (diff)

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

comment:3 Changed 9 years ago by pomu0325

Cc: pomu@… added

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:5 Changed 8 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: SVN (CKEditor) - OLD3.0

This issue has been reproducible in all versions of IE from CKE 3.0

comment:6 Changed 6 years ago by Jakub Ś

This problem can be reproduced in all browsers in CKE 3.x and 4.x (v4)

comment:7 Changed 6 years ago by Jakub Ś

#6372 was marked as duplicate.

The same thing is happening with every span style (like font -size or font name or font colour) you use e.g.

  • Click on new Page button
  • Press Enter 4 times
  • Type "ABCD", select it and apply: Font-style Comic-Sans, Font-size 26px.
  • Select "BC", press CRTL+C
  • Paste it in one of lines above with CRTL+V or paste button.

comment:8 Changed 6 years ago by Jakub Ś

Worst part is that if you do that in plain contenteditable div i.e.

<div style="border:1px solid blue; margin-top:10px" contenteditable="true">
<p>IE font issue bug - copy part of last line to one of empty lines above</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><span style="font-family: tahoma,geneva,sans-serif;"><span style="font-size: 24px;">ABCD</span></span></p>
</div>

you get the same result thus this looks like IE internal bug

comment:9 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

It looks like CKEditor 4.1 has fixed this issue. When you copy text styled in spans it gets pasted wrapped in spans (not in font).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy