Opened 8 years ago

Closed 8 years ago

#3853 closed Bug (invalid)

[FF3] Script error when opening Ajax sample

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Pending Cc:

Description

To reproduce open nightly Ajax sample. The following exception is thrown:

Permission denied to get property XULElement.accessibleType
load()()ckeditor.js (line 71)
(?)()()ajax.html (line 6)
[Break on this error] q.on('editingBlockReady',function(){var ....body;I.runtimeStyle.marginBottom='0px';

Change History (4)

comment:1 Changed 8 years ago by Damian

This seems inconsistent sometimes. Having re-tried again, I now find the following exception:

Permission denied to get property XULElement.accessibleType
style()()ckeditor.js (line 72)
style()()ckeditor.js (line 72)
create()()ckeditor.js (line 97)
create()()ckeditor.js (line 97)
replace()()ckeditor.js (line 6)
replace()()ckeditor.js (line 6)
d()("uiReady", undefined)ckeditor.js (line 7)
replace()()ckeditor.js (line 6)
d()("uiReady", undefined)ckeditor.js (line 7)
buildDialog()()ckeditor.js (line 107)
resetDirty()()ckeditor.js (line 22)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 19)
add()()ckeditor.js (line 19)
add()(["default"], function(), undefined)ckeditor.js (line 20)
resetDirty()()ckeditor.js (line 22)
resetDirty()()ckeditor.js (line 22)
add()()ckeditor.js (line 20)
t()()ckeditor.js (line 21)
resetDirty()()ckeditor.js (line 22)
t()()ckeditor.js (line 22)
add()()ckeditor.js (line 19)
add()()ckeditor.js (line 19)
t()()ckeditor.js (line 21)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 19)
add()()ckeditor.js (line 19)
add()(["panel", "listblock", "dialogui"], function(), Object basePath=plugins/ fileName=plugin registered=Object)ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 19)
add()()ckeditor.js (line 19)
add()(["styles", "domiterator", "panelbutton", 25 more...], function(), Object basePath=plugins/ fileName=plugin registered=Object)ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 19)
add()()ckeditor.js (line 19)
add()(["about", "basicstyles", "blockquote", 46 more...], function(), Object basePath=plugins/ fileName=plugin registered=Object)ckeditor.js (line 20)
add()()ckeditor.js (line 20)
add()()ckeditor.js (line 20)
t()()ckeditor.js (line 21)
t()()ckeditor.js (line 21)
add()()ckeditor.js (line 19)
t()()ckeditor.js (line 21)
t()()ckeditor.js (line 21)
t()()ckeditor.js (line 21)
replace()()ckeditor.js (line 6)
replace()()ckeditor.js (line 6)
d()("customConfigLoaded", undefined)ckeditor.js (line 7)
replace()()ckeditor.js (line 6)
d()("customConfigLoaded", undefined)ckeditor.js (line 7)
t()()ckeditor.js (line 21)
t()()ckeditor.js (line 21)
resetDirty()()ckeditor.js (line 22)
replace()(undefined, div#editor, 2)ckeditor.js (line 7)
d()(div#editor, undefined)ckeditor.js (line 7)
override()()ckeditor.js (line 8)
override()()ckeditor.js (line 8)
createEditor()ajax.html (line 26)
onclick()ajax.html (line 1)
[Break on this error] I.runtimeStyle.marginBottom='';}},1000);...ble:1,td:1,tr:1,ul:1},n=/\s*(?:;\s*|$)/;

comment:2 Changed 8 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Pending added

I'm unable to reproduce this error even when switching very fast between create and remove editor.

XUL error seems similar to that one from #3745, which as it turned out was caused by some FF addon. There are many reports on the Net about XULElement.accessibleType and firebug, but none is confirmed. Whats more strange, error line you've posted comes from IE-only function, but this is most probably due to packed code.

Could you please try to reproduce it on clean FF profile ? It would also be helpful if you post error message from source, not release. This would allow us to find the exact place which causes the issue.

comment:4 Changed 8 years ago by Damian

Resolution: invalid
Status: assignedclosed

Can't reproduce in clean profile. Closing.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy