Opened 10 years ago

Closed 10 years ago

#4041 closed Bug (fixed)

[IE] Remove multiple rows doesn't work

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Styles Version:
Keywords: IE Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the 'replace by class' sample page.
  2. Load the document with following content and selection:
    <table>
    	<tbody>
    		<tr>
    			<td>
    				[row1</td>
    		</tr>
    		<tr>
    			<td>
    				row2]</td>
    		</tr>
    	</tbody>
    </table>
    
  3. Open context menu and 'row' submenu, click 'Delete Rows'.
    • Actual Result: Only row2 get deleted.

Attachments (4)

4041.patch (1.2 KB) - added by Garry Yao 10 years ago.
4041_2.patch (879 bytes) - added by Garry Yao 10 years ago.
4041_3.patch (834 bytes) - added by Garry Yao 10 years ago.
4041_4.patch (823 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:2 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

Changed 10 years ago by Garry Yao

Attachment: 4041.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I'm having an undesired effect after the patch. The prooblem is that the selection is "always" restored in the editor, even if I'm clicking out of it to close the context menu. TC:

  1. Open the editor in a page that can be scrolled.
  2. Select some text and open the context menu for it.
  3. Scroll down the page with the mousewhel, so the context menu will not get closed. Do that until the editor is not anymore visible.
  4. Click at the page... it will scroll up to show the restored selection.

Changed 10 years ago by Garry Yao

Attachment: 4041_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Find an alternative solution for it without any draw backs.

comment:7 Changed 10 years ago by Garry Yao

#3678 has been marked as a DUP.

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The proposed patch will not work withe the following selection case:

<table>
	<tbody>
		<tr>
			<td>
				<strong>r[ow1</strong></td>
		</tr>
		<tr>
			<td>
				<strong>row]2</strong></td>
		</tr>
	</tbody>
</table>

comment:9 Changed 10 years ago by Garry Yao

#4647 has been marked as a DUP.

Changed 10 years ago by Garry Yao

Attachment: 4041_3.patch added

comment:10 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Note that it's even not an ultimate solution, actually the issue is not limited to only 'table element', instead all elements that been displayed as control type is effected including but not limited to the following:

  1. Floated block. See #3670
  2. Sized block. e.g. <p style="width:300px">paragraph</p>

After closed this ticket, we should investigate on the proper way to enumerate/determinate this kind of elements for handling them in a similar manner with this case.

comment:11 Changed 10 years ago by Garry Yao

Manual TCs added at : http://ckeditor.t/tt/4041/1.html

comment:12 in reply to:  10 Changed 10 years ago by Garry Yao

  1. Floated block. See #3670
  2. Sized block. e.g. <p style="width:300px">paragraph</p>

Oops, wrong ticket link above, should be:

  1. Floated block. See #3678
  2. Sized block. See #4647

comment:13 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The patch is got... there is a minor improvement we could have on it. The "target" variable is not anymore needed. In fact, by moving evt.data.getTarget() inside the if check, we avoid executing it if the button is different of "2".

The R+ will come immediately after this small change.

Changed 10 years ago by Garry Yao

Attachment: 4041_4.patch added

comment:14 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:15 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:16 Changed 10 years ago by Garry Yao

Fixed with [4521].

comment:17 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy