Opened 6 years ago

Closed 5 years ago

#4647 closed Bug (fixed)

Image info doesn't fill up dialog when open from context menu

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.2
Component: UI : Context Menu Version: SVN (CKEditor) - OLD
Keywords: IE Review+ Cc:

Description (last modified by garry.yao)

  1. Open the 'replace by class' sample page in IE6, load the editor with following content and selection:
    	<p style="width:200px">[<img src="http://dev.fckeditor.net/chrome/site/logos.gif" />]</p>
    
  2. Right click to open context menu and select 'Image';
  • Actual Result: The 'Url' field is empty in opened dialog.

Attachments (1)

4647.patch (836 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by garry.yao

  • Resolution set to duplicate
  • Status changed from new to closed

Yet another DUP of #4041.

comment:2 follow-up: Changed 6 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2
  • Resolution duplicate deleted
  • Status changed from closed to reopened

It turns out that #4041 will not handle this bug, reopen it.

comment:3 Changed 6 years ago by garry.yao

Manual TCs added at : http://ckeditor.t/tt/4647/1.html

comment:4 in reply to: ↑ 2 Changed 6 years ago by garry.yao

  • Description modified (diff)

Update missing pre-conditions in description.

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

  • Keywords IE Review? added; IE6 removed

Affected all IE versions, the key to reproduce this bug is to have the selected element's container (paragraph here) has "layout", where re-selecting an image element will fail silently, result in a collapsed selection before the image.
The simplest way of avoid running into this issue is DO NOT forcing the selection into editor when context menu item is clicked.

comment:6 Changed 6 years ago by garry.yao

#5053 has been marked as duplicate.

comment:7 Changed 6 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from reopened to new

comment:8 Changed 6 years ago by garry.yao

  • Status changed from new to assigned

#4749 has been marked as duplicate.

comment:9 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:10 Changed 5 years ago by garry.yao

  • Component changed from UI : Dialogs to UI : Context Menu
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5006].

comment:11 Changed 5 years ago by guikubivan

  • Milestone changed from CKEditor 3.2 to CKEditor 3.x
  • Priority changed from Normal to High
  • Resolution fixed deleted
  • Status changed from closed to reopened

This is still a problem unfortunately. I just copied the sample html into the source in the demo page (ckeditor.com/demo) and the first time I right click the image I don't get the "Image Properties" option. However, if I then right-click on the image again OR if I left click the image and then click the Image button, I get the "Image Properties" option and the dialog loads correctly.

If it matters, I am running IE8 (32-bit) in Windows 7 (64-bit).

comment:12 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.x to CKEditor 3.2
  • Priority changed from High to Normal
  • Resolution set to fixed
  • Status changed from reopened to closed

Please do not reopen tickets that have been already fixed. Maybe we have the regression because of something else that needs to be checked.

I would ask you to please open a new ticket for this issue, including all the necessary information to reproduce the problem and eventually a reference to this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy