Opened 13 years ago

Closed 12 years ago

#410 closed Bug (fixed)

[ Firefox ] Any dialog box is not showed properly (ok, cancel buttons lost)

Reported by: Bakyt Niyazov Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: FCKeditor 2.4.2
Keywords: Cc: priebe@…, smpdawg@…, franp@…

Description

Here is my suggestion for fix :)

I've fixed it by opening fckeditor/fckdialog.html

  1. step

find

<table height="100%" cellspacing="0" cellpadding="0" width="100%" border="0">

change it to

<table id="_fckpopup_main_table" height="100%" cellspacing="0" cellpadding="0" width="83%" border="0">
  1. step

add the following code right before closing BODY tag

<!--[if IE]>
	<script type="text/javascript">
		var x = document.getElementById("_fckpopup_main_table");
		x.width = "100%";
	</script>
<![endif]-->

HTH!

Attachments (2)

firefox-issue.gif (5.5 KB) - added by Bakyt Niyazov 13 years ago.
Firefox dialog box's width issue
fit_window.jpg (18.0 KB) - added by Bakyt Niyazov 13 years ago.
Dialog doesn't fit to the window with my "fix"

Download all attachments as: .zip

Change History (20)

Changed 13 years ago by Bakyt Niyazov

Attachment: firefox-issue.gif added

Firefox dialog box's width issue

comment:1 Changed 13 years ago by Alfonso Martínez de Lizarrondo

Keywords: firefox dialog popup removed
Milestone: FCKeditor 2.4.3

This problem happens if you have the Extended Statusbar extension installed.

comment:2 Changed 13 years ago by Bakyt Niyazov

Yes you're almost right. I don't have exactly this extension installed. But I have many other extensions installed.

I tried just to turn off status bar showing and my "fix" lead to the another problem.

is there any workarounds?

Thank you!

comment:3 Changed 13 years ago by Bakyt Niyazov

I've found that any extension that change the status bar

I've disabled SearchStatus - and everything worked fine.

I think this ticket is invalid now :(

FCKEditor is great! Keep up your great work!

Best wishes1

comment:4 Changed 13 years ago by Alfonso Martínez de Lizarrondo

Resolution: invalid
Status: newclosed

comment:5 Changed 13 years ago by Mark

Resolution: invalid
Status: closedreopened

I think this ticket should be re-opened.

I have found that this problem (or a problem that manifests itself in the same way) occurs in IE7 as well.

I originally came to the same conclusion, that it was extensions that change the status bar that cause this problem. However, a user was able to demonstrate to me that this also occurs in IE7, I have not been able to replicate it myself, but she was getting the problem consistently in IE7 until she restarted her machine.

Also I think it should be fixed for Firefox because we should not be stopping our users from using certain Firefox Extensions just so they can use a dialog!

You say that the above "fix" leads to another problem? What is this? Can we work from there and try and find a solution that works?

comment:6 Changed 13 years ago by Mark

Also I should mention that I have witnessed (in Firefox) the checkbox's on the Word Paste dialog get cropped at the bottom so that only one is visible. So there is not just a width problem.

comment:7 Changed 13 years ago by Bakyt Niyazov

CapnPolo I totally agree with you. Forcing users to not to use extensions is a bad idea. My fix lead to the situation when user have no specific (status bar affected) firefox extension the dialog box width less than.

Sorry for my English. Please look at the image I've attached.

Changed 13 years ago by Bakyt Niyazov

Attachment: fit_window.jpg added

Dialog doesn't fit to the window with my "fix"

comment:8 Changed 13 years ago by Bakyt Niyazov

CapnPolo

At this time I see the possible solution in increasing the width of the window.

Or may any other expert (one of the core developers) could find the solution as they know all the inner working of this wonderful html editor.

Best regards.

comment:9 Changed 13 years ago by Bakyt Niyazov

OMG, the simplest solution is to turn off the status bar when invoking the dialog box.

Actually I don't where it is happened (routine the invokes the dialog box)

comment:10 Changed 13 years ago by Bakyt Niyazov

Trying to pass "status=no" to the window.open wasn't successful.

Here http://developer.mozilla.org/en/docs/DOM:window.open#Note_on_status_bar and http://kb.mozillazine.org/Dom.disable_window_open_feature.status

I come to the idea that it is not possible to turn off status bar.

Couldn't find why it is so..

comment:11 Changed 13 years ago by Alfonso Martínez de Lizarrondo

Users can install any extension that they please, but if it creates a bug in the rendering on the browser so that it's quite complex to workaround it, then the extension author should be the one to fix his extension.

I think that previously the extension that I mentioned had lots of other comments reporting the problems with popup dialogs but now only one remains: https://addons.mozilla.org/en-US/firefox/addon/1433

With regards to the IE7 issue, it will be hard to fix it if the same user can fix the problem just by resetting her computer, that's a very hard to reproduce bug, so it's not possible to know what's going on there.

And anyway, this problem will go away if #35 is implemented (use floating panels for dialogs)

comment:12 Changed 13 years ago by Alfonso Martínez de Lizarrondo

Cc: priebe@… smpdawg@… franp@… added

comment:13 Changed 13 years ago by Bakyt Niyazov

Why not just make popups resizable?

comment:14 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 3.0

comment:15 Changed 12 years ago by Bjorn

why not just place the buttons on the left side of the popup. making the popups resizable would also solve the problem

quickfix: in fckdialog.html @ line 323 change

<tr>
<td width="100%">&nbsp;</td>
<td nowrap="nowrap">
<input id="btnOk" style="VISIBILITY: hidden;" type="button" value="Ok" class="Button" onclick="Ok();" fckLang="DlgBtnOK" />
&nbsp; 
<input id="btnCancel" type="button" value="Cancel" class="Button" onclick="Cancel();" fckLang="DlgBtnCancel" />
</td>
</tr>

to

<tr>
<td nowrap="nowrap">
<input id="btnOk" style="VISIBILITY: hidden;" type="button" value="Ok" class="Button" onclick="Ok();" fckLang="DlgBtnOK" />
&nbsp; 
<input id="btnCancel" type="button" value="Cancel" class="Button" onclick="Cancel();" fckLang="DlgBtnCancel" />
</td>
<td width="100%">&nbsp;</td>
</tr>

so just move the first table cell: <td width="100%">&nbsp;</td>

This way the buttons will be visible, no matter what...

comment:16 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 3.0FCKeditor 2.6

This one is supposed to be fixed for version 2.6 (#35).

comment:17 Changed 12 years ago by Martin Kou

Owner: set to Martin Kou
Status: reopenednew

comment:18 Changed 12 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with #35.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy