Opened 9 years ago

Closed 9 years ago

#4548 closed New Feature (fixed)

Fake comment plugin

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Confirmed Review- Cc:

Description (last modified by Frederico Caldeira Knabben)

A fake comment plugin that displays HTML comments with specified pattern as placeholders.

Attachments (6)

4548.patch (3.5 KB) - added by Garry Yao 9 years ago.
4548_2.patch (5.0 KB) - added by Garry Yao 9 years ago.
4548_3.patch (9.4 KB) - added by Garry Yao 9 years ago.
4548_4.patch (12.9 KB) - added by Garry Yao 9 years ago.
4548_5.patch (9.1 KB) - added by Garry Yao 9 years ago.
4548_6.patch (6.2 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Ticket Test added at : http://ckeditor.t/tt/4548/1.html.

Changed 9 years ago by Garry Yao

Attachment: 4548.patch added

comment:2 Changed 9 years ago by Garry Yao

Keywords: Drupal Review? added

Changed 9 years ago by Garry Yao

Attachment: 4548_2.patch added

comment:3 Changed 9 years ago by Garry Yao

As denoted by Wiktor, the comment would be more useful been displayed as a block in the editor, whic h make the requiring of changes to core codes as a mandatory.
Ticket Test has been also updated in this sense at: http://ckeditor.t/tt/4548/1.html.

comment:4 Changed 9 years ago by Garry Yao

After discussing with Wiktor, the display name and style of individual comment should also be configurable, update the TC accordingly and attach a new patch.
It's noticed that the patch even fix a bug of the htmlFilter which doesn't allow more 3+ 'catch all ($)' rules to be registered in one filter instance.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Drupal removed

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The isKnown variable is being added to _source/core/htmlparser/fragment.js but it's never used.

Changed 9 years ago by Garry Yao

Attachment: 4548_3.patch added

comment:7 Changed 9 years ago by Garry Yao

Keywords: Review? added; Review- removed

As Wiktor pointed out that the previous patch was missing the whole plugin codes :(

Changed 9 years ago by Garry Yao

Attachment: 4548_4.patch added

comment:8 Changed 9 years ago by Garry Yao

  1. Adding 'drupalpagebreak' plugin ask Wiktor asked;
  2. Fixing a bug where inline style is not applied on fake comment;
  3. Update a feature where fake comment get another css class name according to the fake name (thanks Pawel for the code).

comment:9 Changed 9 years ago by Garry Yao

Ticket Test added at :
http://ckeditor.t/tt/4548/2.html.

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
  • It looks like the "drupalpagebreak" inclusion was a misunderstanding. Wiktor just wanted to show how they are using the feature.
  • Making this feature so generic is also making its implementation much more complex than needed. Couldn't the Drupal plugin simply handle this case by its own? Maybe the right thing is having us helping Wiktor and Pawel to develop their plugin.

In general, more discussion is needed around this feature. Please contact me.

Changed 9 years ago by Garry Yao

Attachment: 4548_5.patch added

Changed 9 years ago by Garry Yao

Attachment: 4548_6.patch added

comment:11 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Confirmed to be fixed by #4729.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy