Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4707 closed Bug (fixed)

CKEditor image Toolbar resubmits on click in IE 7 and FireFox 3.0.x

Reported by: Shivakumar Kandasamy Owned by: Wiktor Walc
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

Hi,

When I click the image icon in CK Editor, the Image Properties

is displayed. The issue noted is:

1)The page url gets resubmitted in Firefox/3.0.15

2)An empty url gets submitted in IE7

On close of Image Properties an empty url gets submitted in IE7 and gets aborted.

This cause lot of issue as duplicate records get created and empty mails sent to the user.

I have searched google for the last two days but could not find any solution.

Any help in this regard is appreciated.

Attachments (2)

image_properties_resubmits.JPG (137.1 KB) - added by Shivakumar Kandasamy 8 years ago.
image_properties_resubmits snapshot
4707.patch (1.7 KB) - added by Wiktor Walc 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by Shivakumar Kandasamy

Summary: CKEditor image Toolbar resubmits on click in IE 7 and FireFox 3.0.10CKEditor image Toolbar resubmits on click in IE 7 and FireFox 3.0.x

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added; Image Properties resubmit removed

It works for me with no issues. Are you able to reproduce it at our online demo?

Changed 8 years ago by Shivakumar Kandasamy

image_properties_resubmits snapshot

comment:3 Changed 8 years ago by Shivakumar Kandasamy

I was able to reproduce it in the demo using HttpWatchProfessional. I have attached the snapsot of the same.

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; WorksForMe removed
Milestone: CKEditor 3.2

Ok, now I understood the problem better. It happens with the image dialog only. It may be related to the preview image.

comment:5 Changed 8 years ago by Shivakumar Kandasamy

Priority: NormalHigh

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

#4715 has been marked as DUP.

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Priority: HighNormal

Changed 8 years ago by Wiktor Walc

Attachment: 4707.patch added

comment:8 Changed 8 years ago by Wiktor Walc

Keywords: Review? added

It seems that the problem is in empty "src" attribute.

An alternative to removing it would be setting "src" to something like CKEDITOR.basePath + 'images/spacer.gif', but this way we would have another HTTP request.

comment:9 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed

The preview image is hidden by default, so no worry about the place holder image.

comment:10 Changed 8 years ago by Shivakumar Kandasamy

Hi,

Thanks for your prompt response. Now the image onclick problem seems to be resolved but the problem still persist in the image dialog close event and cancel event.

Any help in this regard is appreciated.

Thanks for your co-operation

comment:11 Changed 8 years ago by Wiktor Walc

I cannot reproduce issues with closing image dialog (or canceling changes).

Could you check the patch using one of the samples provided with CKEditor (replacebyclass.html for example, just to be sure that issue is not caused by custom javascript on your web site)?

Please attach new screenshot with all HTTP requests made by IE7 after CKEditor is loaded to help us understand better the problem. When testing it on IE7/IE8 + Fiddler I didn't note any invalid http requests, only an image url is requested by the image dialog.

comment:12 Changed 8 years ago by Frederico Caldeira Knabben

Owner: set to Wiktor Walc

comment:13 Changed 8 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [4715].

comment:14 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.1
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy