Opened 8 years ago

Closed 8 years ago

#4930 closed Bug (fixed)

Dialogs are broken in V2 and Office 2003 skin

Reported by: Wiktor Walc Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc: ckeditor@…

Description

(regression).

Confirmed in every tested browser: IE8, IE6, Opera 10, Safari 4, FF 3.5, although the results are a bit different in every browser. I have attached a screenshot from IE6.

Previously dialod windows had fixed width, now the size of a dialog box depends on elements inside of it.

Attachments (2)

ie6_dialog.png (8.3 KB) - added by Wiktor Walc 8 years ago.
4930.patch (8.4 KB) - added by Frederico Caldeira Knabben 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Wiktor Walc

Attachment: ie6_dialog.png added

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

This happens on the release version only. The uncompressed trunk is ok.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newassigned

This is due to the changes in the skin.js files introduced with [4470]. In effect the "dialogPluginReady" event is fired too early for the release version.

Changed 8 years ago by Frederico Caldeira Knabben

Attachment: 4930.patch added

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review? added

comment:4 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [4868].

comment:6 Changed 8 years ago by Kingsquare

Cc: ckeditor@… added
Resolution: fixed
Status: closedreopened

In the latest nightly build @ http://nightly.ckeditor.com/4871/_samples/skins.html in IE6, the OK button of the link and image dialog are not clickable with the v2 or office 2003 skin.

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

I've opened a new ticket for this issue: #4954.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy